Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an issue with a "N40L" HP Proliant Microserver. When the server is powered on the power light turns green but the machine's status light (the HP logo on the front) stays off and there is no video output through th onboard VGA. The system fan kicks in and if connected to a network the link light shows activity. I have no extra boards (iLO card, graphics card) only 4GB PNY non-standard stick of RAM.

share|improve this question
add comment

1 Answer

up vote 19 down vote accepted

TL;DR - it's the MiniSAS

First things I tried was basic troubleshooting - different VGA cable, different power cable. No luck there so I tried with the original RAM - still no progress.

I logged a job with HP who diagnosed a motherboard fault and sent out a replacement board. After swapping the boards over I started the machine up with video and a blue (good) status light but realised the MiniSAS cable wasn't plugged in and once I did the machine refused to boot.

I was sent a new MiniSAS cable and managed to replace it - not an easy job. The server booted and is now working as expected.

If you have this issue, try unplugging the MiniSAS and see if the system boots. If it doesn't, contact HP or find a supplier for a HP Part Number: 616572-001 or HP Spare number 624881-001. The cable looks like this: enter image description here

I had difficulty finding instructions to replace the cable so here is how I did it. HP also provide an instruction video here.

To remove the MiniSAS cable you will need to remove the MiniSAS from the motherboard (can be difficult) and for ease of access remove the motherboard and tray, and the 4x Hard disk caddies. You will then need to remove 4 screws at the back of the chassis. The allen key that comes with the machine and should be stored in the door can be used for this. The locations are marked below. enter image description here

Once the four screws are removed the MiniSAS cable needs to be fed back though the chassis, over the power supply, but you will need to cut a number of cable ties to do this. Then you will need to disconnect the 4 Molex connectors (if you have a hard disk or CD/DVD drive in the top bay this will need to be removed to gain access to the cables). This was not easy as 1 of the cables was very stiff and needed some coaxing to come out.

Once the screws and cables are loose the rear panel that was unscrewed can be removed - I had to bring it forward feeding the cables down behind it and then rotate it so it could slip out between a center stand in the disk caddy area. You then end up with this (actually upside-down here). enter image description here

The cable can then be disconnected from the mounting plate - 8 screws can be removed using the tool that comes with the server. The replacement cable can be pushed into place (small plastic bumps line up with holes in the rear and then screwed in. The plate can be put back into place, feeding the cables up past the fan, and then screwing back into place. Molex cables need to be connected back up, the MiniSAS fed back through over the PSU. Motherboard can be put back into place and MiniSAS, Power and other connectors can be done as well.

Put the door back on, cover on, power in and VGA in and start it up. That should be it.

Good luck.

share|improve this answer
    
+1 for a thorough write up of how you got it to work! –  Earlz Sep 28 '12 at 14:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.