Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I create a virtual machine in Hyper-V and set it up to use dynamic memory, the virtual machine will always use the maximum memory within the virtualized OS. Hyper-V will show the assigned memory at 514mb, but when I log into the server and pull up task manager, it will show 90% memory used. When I bump the maximum memory up to 4gb, I get the same result: 90% memory usage.

Hyper-V View

Task Manager on VM

Nothing is even running on the virtual machine other than a clean instal of Windows Server 2008 R2. I have also tried it with Windows 7 with the same results. Is this the expected behavior or is something setup wrong

share|improve this question

Look at it this way. If you thinly provision a virtual disk drive, how big does that disk drive look in the guest OS's user interface? It looks like it's fully provisioned.

You're looking at the same thing here. The guest OS thinks that it could use as much as the maximum memory that you specified. On the other hand, you're not using that memory for anything productive within the VM. So the Dynamic Memory integration component installed in that guest OS "allocated" most of it and gave it back to the hypervisor. This is why your UI screen shot (above) looks like most of the memory in the VM is used.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.