Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I run make inside my installed nginx directory I get the output:

make -f objs/Makefile
make[1]: Entering directory `/home/ec2-user/nginx/nginx-1.2.4'
objs/Makefile:110: *** multiple target patterns.  Stop.
make[1]: Leaving directory `/home/ec2-user/nginx/nginx-1.2.4'

make: * [build] Error 2

I am on an Amazon Linux AMI.

The steps I took from the beginning was

wget /path/to/nginx/tarball
tar xvf nginx-1.2.4.tar.gz
cd nginx-1.2.4
./configure --prefix=/nginx --a-bunch-of-other-options

Then I ran make.

Also I installed make by running sudo yum install make

Please let me know if there's any other information I should be providing.

share|improve this question
    
please paste the full log of your failed build –  Hex Sep 29 '12 at 2:05
    
@Hex ok the full output is there –  Justin Meltzer Sep 29 '12 at 2:07
    
If you are not using custom parameters for your Nginx build, you may find it much easier to just install Nginx binary from the Nginx repository. The options used are good for most installations (with the added advantage of updates being easily installable). If you are interested, instructions for setting up the Nginx repository can be found on the Nginx Wiki (For Amazon's Linux, use the instructions you would for CentOS6). –  cyberx86 Sep 29 '12 at 2:23
    
@cyberx86 yeah I ended up installing it through yum –  Justin Meltzer Sep 29 '12 at 2:41
add comment

1 Answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.