Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

While I could use memcached on Debian to use the default 11211 port, but I've had great difficulty setting up unix socket, Form what I'v read, I know that I need to create a memcache.socket and add

-s /path/to/memcache.socket
-a 0766

To /etc/memcached.conf and comment out the default connection port and IP, i.e.

-p 11211 
-l 127.0.0.1

However, when I restart memcached I get internal server errors on Drupal site.

I'm trying to implement unix sockets to avoid TCP/IP overhead and boost overal memcached performance, however not sure how much performance gain one can expect of this tweak.

I appreciate your hints or possibly configs to to resolve this.

share|improve this question
    
Assuming memcached is running, did you configure Drupal to use the socket? –  cjc Sep 29 '12 at 12:49
    
Yes, Drupal has been set up to use memcached and works properly when I use port 11211. –  alfish Sep 29 '12 at 13:17
    
Is the /path/to/ fully readable/executable by the user running Drupal? I don't mean the socket file itself; the Drupal user will also need to be able to descend the directory hierarchy. –  cjc Sep 29 '12 at 13:28
add comment

2 Answers

I believe the socket will need to be world executable, not writable. If your seeing a PHP notice message containing errno=32 Broken pipe, adjust Memcached access mask to 0755

-s /path/to/memcache.socket
-a 0755

Also verify that Drupal's Memcached daemon has TCP port of 0 in the configuration. An unset port will default to 11211, and confuse the socket connection.

$conf += array(
    'memcache_servers' => array(
        'unix:///path/to/memcache.socket:0'  => 'default',
    )
);
share|improve this answer
add comment

You may find that just setting the socket path doesn't work. Memcached drops privileges before it creates its socket, though after it's written its PID. It's common to put the socket in /var/run (e.g. as mysql does), but only root can write there, so create /var/run/memcached and chown it to nobody, then set /var/run/memcached/memcached.sock as the socket path. Writing it to /tmp would work too, but by its very nature that could get trashed; sticking it in /var/run is a bit more permanent.

You can check it's working by using netcat to connect to it:

nc -U /var/run/memcached/memcached.sock

Just type stats at the blank prompt; if it's working you'll get a load of output.

share|improve this answer
    
This worked for me, rather than the other answer. Obviously nobody can't write to a root owned folder w/o the appropriate permission. –  DanFromGermany Feb 10 at 10:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.