Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I don't know what else to try... The share in Windows has permissions to "Everyone" set to read/write, which shouldn't matter because I am mounting the share using the administrator name and password.

I am also using -o rw in the mount declaration.

I have tried about a dozen different variations of the mount statement and none of them have produced a writable directory.

Is there ANYTHING else I can try?

EDIT

Windows Server 2008 R2 holds the share in question.

mount -t smbfs -o username=[Administrator],password=[password],rw //192.168.1.200/websites /media/windows is the declaration that Samba tells me should work.

I am trying to mount to Ubuntu 12.04 (using Samba4)

share|improve this question

migrated from stackoverflow.com Sep 29 '12 at 16:26

This question came from our site for professional and enthusiast programmers.

    
This is very short on details. You need to post some versions of the command which produced a read only result, state your windows version, mention if you've been able to write to that directory by sharing it to another windows machine, state if there is read-only access granted to any other users/guest, etc –  Chris Stratton Sep 29 '12 at 4:49
    
If you've tried as much stuff on the Linux side as you can, I'd look at the Windows side. Create a dummy account on the windows box with promiscuous perms on the share, and have Linux connect using that account's credentials. Windows handles the administrator account differently in a lot of ways; this might be a symptom of that. –  Zac B Sep 29 '12 at 16:31
    
First, -t smbfs syntax has been deprecated for a long time and you should be using -t cifs. Second, does your password contain special characters that are not being escaped correctly by the shell? It may be useful to use a password file. –  jgoldschrafe Sep 29 '12 at 16:34
    
@jgoldschrafe Good call about the pass word. Another thing: If the server is part of a domain the userid must be specified as domain\userid. It may also be necessary to use 2 \\ to prevent the shell eating the character after the backslash. (E.g character after the \ is a N, T, F or R.) –  Tonny Sep 30 '12 at 8:40
    
I've still not been given even a clue about what I can try... The password is encapsulated in (')s, so that isn't the issue, and smbfs or cifs; makes no difference. –  aserwin Oct 1 '12 at 1:28
add comment

3 Answers

Samba will not use the SMBv2 protocol that Windows 2008 defaults to; you need to explicitly tell Windows to use the older one.

Go to networking, share options, and switch to "old password sharing" - whatever that option is called there.

It causes Windows to drop the SMBv2 requirement that logons are 128bit AES encrypted, instead allowing the old 56-bit DES, and even passwordless logons.

If this is not the problem, you need to increase logging in samba and report what the problem is.

share|improve this answer
add comment

Did you check that on the Windows side BOTH the file-system AND the share permission are set correctly ? The default for share permission is read-only (as of W2K3).

If you can't mount at all, check out the answer from adaptr.

share|improve this answer
add comment

Samba/Cifs from the command line always gives the ownership to the root user. You will need to specify the gid and uid options.

To mount the drive and give the first user on your system (1000) access to the share for read/write use this command: mount -t smbfs -o username=[Administrator],password=[password],rw,gid=1000,uid=1000 //192.168.1.200/websites /media/windows This gives the ownership of the share to group id 1000 and user id 1000.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.