Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed RVM on ArchLinux x64 in single user mode via the recommended install script

curl -L https://get.rvm.io | bash -s stable

I've also installed all the requirements listed in rvm requirements

However, I'm having trouble actually installing any version of ruby. And getting the following error:

arch:~ % rvm install 1.9.3
No binary rubies available for: ///ruby-1.9.3-p194.
Continuing with compilation. Please read 'rvm mount' to get more information on binary rubies.
Fetching yaml-0.1.4.tar.gz to /home/christopher/.rvm/archives
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                             Dload  Upload   Total   Spent    Left  Speed
100  460k  100  460k    0     0   702k      0 --:--:-- --:--:-- --:--:--  767k
Extracting yaml-0.1.4.tar.gz to /home/christopher/.rvm/src
Prepare yaml in /home/christopher/.rvm/src/yaml-0.1.4.
Configuring yaml in /home/christopher/.rvm/src/yaml-0.1.4.
Error running ' ./configure --prefix=/home/christopher/.rvm/usr ', please read /home/christopher/.rvm/log/ruby-1.9.3-p194/yaml/configure.log
Compiling yaml in /home/christopher/.rvm/src/yaml-0.1.4.
Error running 'make', please read /home/christopher/.rvm/log/ruby-1.9.3-p194/yaml/make.log

Please note that it's required to reinstall all rubies:

    rvm reinstall all --force

Installing Ruby from source to: /home/christopher/.rvm/rubies/ruby-1.9.3-p194, this may take a while depending on your cpu(s)...
ruby-1.9.3-p194 - #downloading ruby-1.9.3-p194, this may take a while depending on your connection...
ruby-1.9.3-p194 - #extracting ruby-1.9.3-p194 to /home/christopher/.rvm/src/ruby-1.9.3-p194
ruby-1.9.3-p194 - #extracted to /home/christopher/.rvm/src/ruby-1.9.3-p194
Skipping configure step, 'configure' does not exist, did autoreconf not run successfully?
ruby-1.9.3-p194 - #compiling
Error running 'make', please read /home/christopher/.rvm/log/ruby-1.9.3-p194/make.log
There has been an error while running make. Halting the installation.

The log files are as follows:

arch:~ % cat ~/.rvm/log/ruby-1.9.3-p194/yaml/configure.log 
__rvm_log_command:32: permission denied: 
arch:~ % cat ~/.rvm/log/ruby-1.9.3-p194/yaml/make.log     
make: *** No targets specified and no makefile found.  Stop.
arch:~ % cat ~/.rvm/log/ruby-1.9.3-p194/make.log     
make: *** No targets specified and no makefile found.  Stop.
share|improve this question

1 Answer 1

Really looks like a permission problem somewhere , try running the

./configure --prefix=/home/christopher/.rvm/usr

at /home/christopher/.rvm/src/yaml-0.1.4 manually in a try to get a better error log , if it's not sufficient you can try to strace the configure command.

Also if it's a fresh install you can

# rvm implode # (run as root)
$ curl -L https://get.rvm.io | bash -s stable --ruby
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.