Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Emails sent by mta from my server recognizes by spam filters as spam and there's message : Received-SPF: neutral ...

Actually, I am not spammer :)

So, I googled around these questions and found that I need setup two things

  1. SPF record
  2. DKIM

Now I am trying to correctly setup and tune on server SPF record.

So, I did already:

a. added spf record to domain hosted zone on amazon.

It's something like this :

"v=spf1 a mx ptr ip4:ip_adress_where_from_i_send_mail -all"

b. checked spf record through spf query lib and also through spf checker http://www.kitterman.com/spf/validate.html

spfquery --scope mfrom --id noreply@mydomain.com --ip ip_adress_where_from_i_send_mail

Result :

Received-SPF: pass

c. setup on server domainname, it was empty, maybe this is useless action, not sure

sudo domainname mydomain.com

but now i get in exim logs :

[4:11:23 PM] Sergey Glazyrin: 
2012-09-29 17:08:15 1THwmF-00086h-2Y <= noreply@mydomain.com U=www-data P=local S=847 id=b1e267a45af62b2132fe36125b00e1ed@mydomain.com
2012-09-29 17:08:15 1THwmF-00086h-2Y aspmx.l.google.com [2a00:1450:4001:c02::1b] Network is unreachable
2012-09-29 17:08:16 1THwmF-00086h-2Y => dev@mydomain.com R=dnslookup T=remote_smtp H=aspmx.l.google.com [173.194.70.27] X=TLS1.0:RSA_ARCFOUR_SHA1:16 DN="C=US,ST=California,L=Mountain View,O=Google Inc,CN=mx.google.com"
2012-09-29 17:08:16 1THwmF-00086h-2Y Completed

And I am not sure what to check/do now ?

share|improve this question

migrated from stackoverflow.com Sep 30 '12 at 2:56

This question came from our site for professional and enthusiast programmers.

2 Answers 2

I don't see what the problem is. It looks like everything's working. The logs say there's some outgoing email, it tries to connect to aspmx.l.google.com via IPv6, it fails so it tries to connect via 173.194.70.27 and is successful, and the last line says it's finished.

share|improve this answer
    
but my emails still are in spam in google mailboxes. and there's message when I see original : Received SPF: neutral. And I think this is one of the reasons why my email in spam. It looks like exim don't want to check SPF domain record although I enabled needed flag CHECK_RCPT_SPF = yes btw, thx for your answer! this is a first answer to my question on stackoverflow :) –  Sergey Glazyrin Sep 29 '12 at 18:53
    
@SergeyGlazyrin Received SPF: neutral is fine. If google blocked for a not-bad-not-good SPF response, 99% of all legit emails not from google would get blocked. SPF is checked by the receiving MTA, to check if the IP that the email is being received from is allowed to send for the envelope From address. Your Exim would be checking SPF for its incoming email. –  Jon Lin Sep 29 '12 at 19:06

To add to Jon Lin's answer, you can get rid of the message. Disable ipv6 in your exim build or disable it at runtime by adding to the global options in your exim.conf:

disable_ipv6 = true
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.