Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am a new to virtual box environment. I installed virtualbox-4.2 in Ubuntu 12.04 32 bit system. Now i am trying to import a 64 bit operating system. I got the following error.

Failed to open a session for the virtual machine localvm.
VT-x is not available. (VERR_VMX_NO_VMX).


Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
Console
Interface: 
IConsole {db7ab4ca-2a3f-4183-9243-c1208da92392}

I tried to make my question clear but if its not clear any edits are welcome and help me to come out from this.... thank YOu

share|improve this question

closed as not a real question by Michael Hampton, Ward, Scott Pack, Magellan, Ladadadada Oct 8 '12 at 11:52

It's difficult to tell what is being asked here. This question is ambiguous, vague, incomplete, overly broad, or rhetorical and cannot be reasonably answered in its current form. For help clarifying this question so that it can be reopened, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
The error pretty much explains the issue -- VT-x is not available. –  David Schwartz Oct 1 '12 at 10:29
    
Can you explain what can be done to resolve this error –  DomincJune Oct 1 '12 at 10:31
    
Troubleshoot to figure out what's causing it and fix whatever the cause is. Does the CPU support VT-x? Is it enabled in the BIOS? ... –  David Schwartz Oct 1 '12 at 10:56

2 Answers 2

up vote 3 down vote accepted

In order to run 64-bit virtual machines on a 32-bit platform, you need hardware virtualization support. It is called VT-x for Intel processors, and AMD-V for AMD. It seems it isn't available on your system. Check the BIOS, it may have been turned off, or check if your processor indeed supports hardware virtualization.

share|improve this answer
    
..and check the VM settings in virtualbox, if it's enabled for that virtual machine (should be by default i think). –  mulaz Oct 1 '12 at 10:25
    
I checked the Bios information its is as follows ....BIOS is upgradeable –  DomincJune Oct 1 '12 at 10:30
    
It doesn't matter whether the BIOS can be upgraded or not. Look for "VT-x" or "AMD-V" in the BIOS settings. If you can't find them, then most probably your processor doesn't support HW virtualization. –  Lacek Oct 1 '12 at 10:32

you can try this command: egrep -i "vmx|svm" /proc/cpuinfo to verify the presence of virtualization extensions. You should also check your VMs settings under VM settings -> System -> Acceleration and check the first box.

In order to run a 64-bit guest on a 32-bit OS you are still required to have a 64-bit CPU with VMX/SVM. See VirtualBox manual

share|improve this answer
    
Hi there, I tried to egrep -i "vmx|svm" /proc/cpuinfo i didnt get any output.... –  DomincJune Oct 1 '12 at 10:47
    
I also checked the VM settings but my Accleration is not activated. –  DomincJune Oct 1 '12 at 10:51
    
No output indicates that your CPU doesn't support any virtualization features, but according to the vbox manual (link in post above) these features are required in order to run 64-bit guests. So I would say you have to replace your CPU. –  olvrlrnz Oct 7 '12 at 21:54

Not the answer you're looking for? Browse other questions tagged or ask your own question.