Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a hair pulling issue with my VSFTPD. I am not sure where to turn and I have went through to make sure everything is working properly and when trying to connect to ftp using ftp localhost I am able to login with the username and password I have specified. When I try to connect from outside I get the prompt Connected to domainname.com. but no prompt for user and password in addition when using an FTP client it hangs up and never connects.

The server is running Ubuntu 12.04 LTS and VSFTPD 2.3.5

Here is the output of running iptables -L : http://pastie.org/4892233

Here is he output when running ps -FC vsftpd :

root     14343     1  0  1168   984   3 16:55 ?        00:00:00 /usr/sbin/vsftpd

Here is output of running netstat -tlpn | grep vsftpd :

tcp6       0      0 :::21                   :::*                    LISTEN      14343/vsftpd    

I have uninstalled and reinstalled many times and tried several different configurations and am at a complete loss on why this may not be working. We very often use the same configuration on the same type of servers with no issues.

Thank you in advance for your help.

share|improve this question
    
hangs up and never connects in what way, do you maybe get a message like this "227 Entering Passive Mode...", are you trying to access your server from internal network or by the public IP –  Alen Oct 1 '12 at 17:26
    
HI @Alen - Thanks for your reply. The message I just got from trying to connect via ip was: Connected to XX.XXX.XX.XX. 421 Service not available, remote server timed out. Connection closed. –  jnolte Oct 1 '12 at 17:33
    
Looks like something is blocking ftp connections between the client and the server, are you connecting from the client in the same subnet as the server, or are you going over some router or firewall. Also as I recall vsftpd is by default set to listen on port 20 not 21 check that, did you enable passive mode on vsftpd, and are you on the client using passive mode or active, what client are you using –  Alen Oct 1 '12 at 17:44
add comment

1 Answer

The output to the netstat command looks like vsftpd is listening only on IPv6. To get it to listen on IPv4, try commenting out the line:

listen_ipv6=YES

and replace it with:

listen=YES

in your vsftpd.conf file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.