Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The graphic (below) shows the fault I am seeing in VMWare Infrastructure Client, the drive0 light is also flashing. Not sure why, the other drive lights are green. Can't see any errors in the logs and VM's are running sweet. I got up super-early and rebooted it this morning (production box, so I'm paranoid). It came up and all the status lights went green.. but I get into the office and its back on red.. Is there anything I can do to troubleshoot this? I think reinstalling ESX might fix it, haven't tried that yet.

Main points:

  • Server has 4 x 149GB SAS Drives in front hot-pluggable bays. AFAIK, no other drives.
  • They are RAID5'd into one big datastore, which is reporting no errors. (See below, Logical Volume)
  • The warranty has just expired.
  • SAS 1078 MegaRAID controller
  • Just checked physically, and the machine is reporting the following error on its tiny little status LCD: "System Software Event: Drive Slot Sensor: drive fault was asserted" Which is about as helpful as the other message. Can't seem to clear this.

I haven't found any iLO/DRAC interfaces on the back of the box, and I've only been here for a few weeks, so still struggling to adapt to ESX's weird ways. Why is IC showing 8 drive faults? I can't find anything about this online.. I thought I was good at googling!

Only four drives in bay, but showing fault on 8

EDIT: Now its back: (And you can see there are 4 drives in there, 1 hot-spare, didn't notice Drive0 was missing before)

Its alive

share|improve this question
    
Ok, fixed it. Changed faulty drive with new one, all systems go, all lights back to Normal, no more Assert Failure.. Not sure how I was supposed to know to replace that exact drive without going to the machine and seeing that light flashing and guessing that it meant replace me now.. not happy ESX. If anyone knows how to find some raid-utility or low-level disk anything on one of these without powering down, I would love to know, and would consider it the answer to the question. Its currently rebuilding the RAID.. –  Grizly Oct 15 '12 at 1:23

1 Answer 1

up vote 0 down vote accepted

It was a faulty drive, check the physical box for failure lights, replace, wait for rebuild, should be good.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.