Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an exchange mailbox called "Support" with two email addresses: foo@company.com (primary) bar@company.com

Mail to both addresses goes to the same inbox correctly and message show as To: Support. if I check the details of the To: field it always shows foo@company.com, even when messages were sent to bar@company.com. Viewing the full message headers shows bar@company.com

How can I get Outlook to show the actual email address the message was sent to? It's an issue for the people managing the mailbox because knowing what the target address was is important to determine how the message should be handled.

share|improve this question
    
I think that the 'foo@company.com' address is default (created from account name), and the 'bar@company.com' is only alias so you can add rule (in outlook with option 'send to') to separate those mails to different sub-folders (for example inbox/foo and inbox/bar) by checking header. Check this out, please. I think that, the 'rules' is only good way to solve your problem. –  Dawid Meyer Oct 2 '12 at 6:44
    
@japao: It would still be mangling the to field though. So while that would work, it still wouldn't be a very good solution. Can there really be no way to keep it from mangling the fields? –  David Schwartz Oct 2 '12 at 6:50
    
Ok, if that rule is not working, please try to use rule named "with specific words in the recipient's address" and put in alias name. In my Outlook it's working. –  Dawid Meyer Oct 2 '12 at 7:02
    
I found this now: support.ravenit.com/entries/… –  Dawid Meyer Oct 2 '12 at 7:08

2 Answers 2

In the end I gave up on unmangling the address; using a rule on "specific words in the recipient's address" was promising but turned out to be a client-only rule, not practical with multiple users to be co-ordinated.

What I did was create a mailbox for every address, all of them set to forward to the combined mailbox under Exchange General -> Delivery Options. Now when outlook resolves a to: address it finds the mailbox for just that address, and then displays the default address of that mailbox.

share|improve this answer

Alternative to try is to use a distribution list (which can also have multiply aliases) which forwards the mail to the destination mailbox and will show the original to address.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.