Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My sshd_config looks like this:

Match User c_upload
        ChrootDirectoy /var/www/upload
        ForceCommand internal-sftp

etc/init.d/ssh restart fails with this message:

/etc/ssh/sshd_config: line 90: Bad configuration option: ChrootDirectoy
/etc/ssh/sshd_config line 90: Directive 'ChrootDirectoy' is not allowed within a Match block

My openssh-server version (according to dpkg AND ssh -v) is 5.5p1. According to the manual I should be able to use the ChrootDirectory option.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

You can't see for looking you are missing the r from Directory

ChrootDirectory /var/www/upload

should do the trick.

share|improve this answer
    
OMG! I am such a blind idiot. That of course did the trick ;-) I even wrote it correctly in the title... –  Zulakis Oct 2 '12 at 11:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.