Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We are migrating our Blue Martini Commerce application (only supported on WebLogic 10.3.0) to a new host (Redhat 6.3 on a VMWare ESX vm). We are seeing extremely slow start up times for our managed server(s) that is basically 20x slower than our current production.

As a for instance the Publish managed server takes ~30 - 45 seconds in current production and in the new environment it takes ~10 minutes.

The setup uses the same domain structure and JVM as the current production environment. The same setup files are used. We use jdk1.6.0_33 on 64 bit architecture. We used the generic 64bit weblogic installer and used pack / unpack utilities to migrate the domain.

The JAVA_OPTS to start this server are: "-d64 -Xms256m -Xmx512m -XX:PermSize=48m -XX:MaxPermSize=256m"

The sysadmins have checked /etc/sysctl.conf and /etc/limits.conf to ensure we were not hitting some kind of process limit. As I am not sure what this managed server does from a Blue Martini perspective during the phase of startup I also had the DBA check to ensure that Oracle RAC (11.2.0.3) wasn't also hitting some kind of process limit or if there was a tns listener issue.

The new host is quite a bit stricter with their server lock downs so there are a few differences....

  • Redhat 6.3 in new env, RH 5.7 in current
  • SElinux is targeted in new env and disabled in current
  • VM in new env and dedicated hardware in current
  • iptables disabled in current. It was enabled in new prod but I had them disable it just in case

I apologize for not being more specific. I am mostly hoping got some tips. I do not have the typical root access I would normally have in this environment. I am just hoping got a path forward. I did a few 'kill -3' to see if there are blocked threads and I got nadda. The service works for all intents and purposes it is just painfully slow.

Thanks you all in advance for reading and best regards. Wade

share|improve this question

migrated from stackoverflow.com Oct 3 '12 at 7:16

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I have experienced the following when initialising the Security Realm specifically with 10.3.0.0 on linux hosts:

(Taken from Here Weblogic Starts Slow)

Turns out Weblogic uses random number generator during start up. Because of the bug in java it reads ‘randomness’ from /dev/random. /dev/random is very good random numbers generators but it is extremely slow. It takes sometimes 10 minutes or more to generate one number. /dev/urandom is not that good, but it is instant. Java somehow maps /dev/urandom file to /dev/random. That’s why default settings in $JAVA_HOME/jre/lib/security/java.security are useless.

One of the solutions from the same page:

...change $JAVA_HOME/jre/lib/security/java.security

Replace securerandom.source with

securerandom.source=file:/dev/./urandom

NOTICE: This approach may have security ramifications, but it may at least give you an explanation.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.