Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

The problem is that my users can not change files in a shared folder (on a mounted drive as folder under D: drive).

These are all the steps that I have tried and are still applicable: (sorry for the lengthy post)

1 - I have created a shared folder on a windows 2008 R2 and I manage it with the files services role.

enter image description here

2 - Using SMB share settings, I gave access to all domain users.

enter image description here

3 - Right click the folder - selecting share with - again - giving every user access

enter image description here enter image description here

4 - Right click the folder -> properties: in the sharing: I made sure all users have access.

enter image description here enter image description here

5 - advanced sharing - also have correct settings

enter image description here

6 - on security settings of the folder properties, again - domain users have full control

enter image description here

7 - I am checking a certain domain member (test) to see if he gets correct effective permissions

enter image description here

  • so, assuming all is correrct, user: test - should have full access to a folder located inside: BUILDS - not.

Getting effective permissions for user test on the folder gives me read access permissions only:

enter image description here

My question:

  1. Why am I gettings wrong permissions for the user test on the folder?
  2. What settings do I need, so users can have full access to the folder/files even if it's not them as the owners.
share|improve this question
    
It's a mounted drive - could that be an issue? (added to question) –  Saariko Oct 3 '12 at 11:48
    
Very possibly - the NTFS permissions of the mount point (i.e. the folder) are not the same as the NTFS permissions of the root of the mounted drive. Check those in Disk Manager on the server –  Chris McKeown Oct 3 '12 at 11:49
    
Eureka - thanks - had to give the drive the correct settings in the disk management window. feel free to post as answer - where were you 3 hours ago :-/ –  Saariko Oct 3 '12 at 11:51
add comment

1 Answer

up vote 4 down vote accepted

If it's a mounted drive as you mention in your comment:

The NTFS permissions of a mount point (i.e. the folder) are not the same as the NTFS permissions of the root of the mounted drive. Check those in Disk Manager on the server.

It's very probable that the share management console is showing you the NTFS permissions of the mount point, not the mounted drive.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.