Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

dI logged into my EC2 console created a new instance and attached an Elastice IP to it. Then I logged into the server and installed Nginx:

$ sudo apt-get install nginx
$ sudo /etc/init.d/nginx start
$ Starting nginx: nginx.

When I navigate to the Elastic IP (or Public DNS) I get nothing. The default setting should be enough to show me the default Nginx welcome page right? I've hit a wall and don't know what to do next. Any suggestions would be much appreciated?

I haven't touched it but here is my default nginx.conf:

user www-data;
worker_processes 4;
pid /var/run/nginx.pid;

events {
    worker_connections 768;
    # multi_accept on;
}

http {

    ##
    # Basic Settings
    ##

    sendfile on;
    tcp_nopush on;
    tcp_nodelay on;
    keepalive_timeout 65;
    types_hash_max_size 2048;
    # server_tokens off;

    # server_names_hash_bucket_size 64;
    # server_name_in_redirect off;

    include /etc/nginx/mime.types;
    default_type application/octet-stream;

    ##
    # Logging Settings
    ##

    access_log /var/log/nginx/access.log;
    error_log /var/log/nginx/error.log;

    ##
    # Gzip Settings
    ##

    gzip on;
    gzip_disable "msie6";

    # gzip_vary on;
    # gzip_proxied any;
    # gzip_comp_level 6;
    # gzip_buffers 16 8k;
    # gzip_http_version 1.1;
    # gzip_types text/plain text/css application/json application/x-javascript text/xml application/xml application/xml+rss text/javascript;

    ##
    # nginx-naxsi config
    ##
    # Uncomment it if you installed nginx-naxsi
    ##

    #include /etc/nginx/naxsi_core.rules;

    ##
    # nginx-passenger config
    ##
    # Uncomment it if you installed nginx-passenger
    ##

    #passenger_root /usr;
    #passenger_ruby /usr/bin/ruby;

    ##
    # Virtual Host Configs
    ##

    include /etc/nginx/conf.d/*.conf;
    include /etc/nginx/sites-enabled/*;
}


#mail {
#   # See sample authentication script at:
#   # http://wiki.nginx.org/ImapAuthenticateWithApachePhpScript
# 
#   # auth_http localhost/auth.php;
#   # pop3_capabilities "TOP" "USER";
#   # imap_capabilities "IMAP4rev1" "UIDPLUS";
# 
#   server {
#       listen     localhost:110;
#       protocol   pop3;
#       proxy      on;
#   }
# 
#   server {
#       listen     localhost:143;
#       protocol   imap;
#       proxy      on;
#   }
#}

There is nothing in access or error logs and I've also ensured nginx is running:

ps -ax | grep nginx
Warning: bad ps syntax, perhaps a bogus '-'? See http://procps.sf.net/faq.html
4305 ?        Ss     0:00 nginx: master process /usr/sbin/nginx
4306 ?        S      0:00 nginx: worker process
4307 ?        S      0:00 nginx: worker process
4308 ?        S      0:00 nginx: worker process
4309 ?        S      0:00 nginx: worker process
share|improve this question

1 Answer 1

up vote 1 down vote accepted

The most likely issue here is that you need to open up port 80 in your EC2 security group settings, so the instance can accept inbound traffic to the web server.

share|improve this answer
    
Thank you, Thank you, Thank you... :) –  jwerre Oct 3 '12 at 18:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.