Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This may be more relevant on stackoverflow, if so please migrate it :-)

I have had to disable automatic updates in Plesk on my Windows server as everytime an update is installed, my php.ini configurations get wiped and I have to re-configure PHP.

I know it is not meant to do this as it does not do it on my Linux server. Has anybody else had this issue? Is there an easy fix?

Thanks in advance

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Just take a "Service Plan" you used for your 50 domains and setup required PHP settings there. All 50 domains will be reconfigured then. If you didn't create your own plans, it is likely that "Default" or "Default Unlimited" plan was used. This information should be shown in Plesk anyway, so find the plan name and edit the plan settings.

share|improve this answer
    
Thank you for your answer, this is in fact what I have done. After managing to sync my php settings throughout each subscription and each subdomain, everything was working fine. The only thing that is not working is loading extensions using the additional parameters text box. I think this is a bug though –  Ben Carey Oct 5 '12 at 7:11
add comment

I have realised the root of problem. Plesk does not support the editing of the PHP.ini, the way to edit the PHP settings is by manually entering the settings in the domain control panel. This is hugely irritating as I have over 50 domains and they all need to same PHP settings.

Hopefully I will just be able to apply a skeleton setting to all the domains

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.