Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This command works:

parallel-ssh -i -O 'IdentityFile=control.pem' -l control  -H example.com 'nohup /home/hubot/runHubot.sh' 2>&1

When I log onto my server, ps shows me that the runHubot script is running. However, this command is not backgrounded so it doesn't return to parallel-ssh

The same command, just with a single & appended to nohup doesn't work. Why?

parallel-ssh -i -O 'IdentityFile=control.pem' -l control  -H example.com 'nohup /home/hubot/runHubot.sh &' 2>&1

This command returns to parallel-ssh, but the hubot script isn't in my ps output.

How can I background this process using parallel-ssh (switching to another program is not an option)?

share|improve this question
    
Does the second command produce a nohup.out? If yes, what's in it? –  ott-- Oct 4 '12 at 16:14
    
no, not creating a nohup.out as far as i can see –  andy Oct 4 '12 at 16:26
    
But then there's no nohup.out script created for the first one either... –  andy Oct 4 '12 at 16:27
    
Does the script produce any output at all? Can you add an echo something to check. Have you considered using screen? –  ott-- Oct 4 '12 at 20:13

1 Answer 1

up vote 0 down vote accepted

Do you see it in ps -elf or ps aux? ps may only be showing you processes with a terminal.

share|improve this answer
    
It's not in either, but i normally use ps aux –  andy Oct 4 '12 at 16:35
    
This does not provide an answer to the question. To critique or request clarification from an author, leave a comment below their post - you can always comment on your own posts, and once you have sufficient reputation you will be able to comment on any post. –  Ward Oct 4 '12 at 18:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.