Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to set up Quagga ospfd on two hosts connected by an OpenVPN link. These hosts have VPN IPs 10.31.0.1 and 10.31.0.13. ospfd config is pretty simple:

hostname bizon
password xxxxxxxxx
enable password xxxxxxxxx
!
log file /var/log/quagga/ospfd.log
!
interface lo
!
interface tun0
ip ospf network point-to-point
ip ospf mtu-ignore
ip ospf cost 10
interface tun1
ip ospf network point-to-point
ip ospf mtu-ignore
ip ospf cost 10
interface tun2
ip ospf network point-to-point
ip ospf mtu-ignore
ip ospf cost 10
!
router ospf
ospf router-id 10.31.0.1
network 10.31.0.0/16 area 0.0.0.0
network 10.119.2.0/24 area 0.0.0.0
redistribute connected
area 0.0.0.0 range 10.0.0.0/8
!
line vty
!
debug ospf event
debug ospf packet all

I am getting the following error in the ospfd.log (the log is from 10.31.0.13):

2012/10/05 01:25:28 OSPF: ip_v 4
2012/10/05 01:25:28 OSPF: ip_hl 5
2012/10/05 01:25:28 OSPF: ip_tos 192
2012/10/05 01:25:28 OSPF: ip_len 64
2012/10/05 01:25:28 OSPF: ip_id 64666
2012/10/05 01:25:28 OSPF: ip_off 0
2012/10/05 01:25:28 OSPF: ip_ttl 1
2012/10/05 01:25:28 OSPF: ip_p 89
2012/10/05 01:25:28 OSPF: ip_sum 0xe5d1
2012/10/05 01:25:28 OSPF: ip_src 10.31.0.1
2012/10/05 01:25:28 OSPF: ip_dst 224.0.0.5
2012/10/05 01:25:28 OSPF: Packet from [10.31.0.1] received on link tun1 but no ospf_interface

I'm not sure what to do next. I have set up ospfd over OpenVPN several times but I used Debian and I am on CentOS 6 now. Quagga version is 0.99.15. Should I try to get more recent version?

tun1      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00  
          inet addr:10.31.0.13  P-t-P:10.31.0.14  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:19888 errors:0 dropped:0 overruns:0 frame:0
          TX packets:859 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100 
          RX bytes:1207870 (1.1 MiB)  TX bytes:70797 (69.1 KiB)
share|improve this question
    
Packets destined to a multicast address suggests the other side may not be configured as a point-to-point interface. It's also interesting that the ospfd process isn't seeing tu1 as a valid interface. How is the IP of the interface being configured? –  rnxrx Oct 4 '12 at 21:47
    
I added tun1 configuration to the question. Basically this address is assigned by the OpenVPN client. –  Alex Oct 4 '12 at 21:54
1  
Do you know what the problem was with OpenVPN? For the future, if you get stuck on how to look at setting up OSPF holistically. this is an excellent OSPF overview certificationkits.com/cisco-certification/… as it is very similar to the type of study guide you will get when you go to one of the CCNP boot camps. It has a slide at the top of each page with a detailed explanation below it to help you troubleshoot issues. –  user202127 Dec 10 '13 at 22:48

2 Answers 2

up vote 1 down vote accepted

I gave up struggling with OpenVPN in tun mode and set up a tap-based OpenVPN. Everything started to work as expected.

share|improve this answer

Try specifying OSPF neighbors explicitly (like here http://www.freeccnaworkbook.com/workbooks/ccna/configuring-ospf-static-neighbors/ )

share|improve this answer
    
I'm not sure how to do it in Quagga, there is nothing relevant in the manual. –  Alex Oct 5 '12 at 7:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.