Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running carbon-cache.py and carbon-aggregator.py using daemon tools. When I made some changes in the storage-schema.conf and tried to restart the carbon-cache.py, I found that it is becoming zombie very frequently.

root      3367  3366  0 03:23 pts/1    00:00:00 supervise carbon-aggregator
root      3371  3366  0 03:23 pts/1    00:00:00 supervise carbon-cache
root      3373  3367  3 03:23 pts/1    00:00:02 /usr/bin/python /usr/bin/carbon-aggregator.py --debug start
root      3379  3372  0 03:23 pts/1    00:00:00 multilog t /var/log/multilog/carbon-cache
root      3382  3368  0 03:23 pts/1    00:00:00 multilog t /var/log/multilog/carbon-aggregator
root      3638  3371 21 03:24 pts/1    00:00:00 [carbon-cache.py] <defunct>

Can someone tell me what may be the reason ?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

The problem was PID file was not getting deleted after I stop the carbon-cache.py i.e it wasn't graceful restart.

I debugged the problem by checking the logs at /var/log/multilog/carbon-cache/current which showed that PID file exists.

After deleting the PID file, the problem was solved completely.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.