Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a 4 servers connected to a HP 2848 switch with uplink to a router (Linux or Cisco - doesn't matter). Total traffic is about 300Mbps with 60-70Kpps.

The problem is with a a port, connected to a router: per TCP connection speed is not more then 20Mbps. To identify this problem I set up an additional port on router, connected it to the same switch and added a route to it - had no problem.

The switch shows it has multiple discards on port (only the worst cases shown):

# walkmib ifOutDiscards    
ifOutDiscards.14 = 76,784
ifOutDiscards.29 = 17,475
ifOutDiscards.30 = 250,741
ifOutDiscards.38 = 1,072,440
ifOutDiscards.43 = 2,661,183
ifOutDiscards.44 = 3,110,164

Enabling of qos-passthough-mode didn't help, lacp is disabled, CPU load on the switch is not more then 10% and there is enough memory.

Where might the problem be?

Thank you!

share|improve this question
    
Have you tried changing the cable...? Sounds obvious, but a bad cable can cause a number of "weird" switching problems. Alternatively, are there any spare ports you could configure this onto, which'd indicate the port's shagged. –  Tom O'Connor Oct 5 '12 at 9:08
    
Is it just a single port that your having issues with? –  Steve Oct 5 '12 at 9:42
    
no, it happens on every port –  Dave Oct 5 '12 at 12:17
    
The issue is now SOLVED: the lack of per port buffer memory leaded to packet drop and TCP session reestablishing, which on high-RTT connections caused the TCP Windows Scaling to reset. Enabling Flow Control on both sides fixed the issue. –  Dave Oct 10 '12 at 16:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.