Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use Windows 7 but I run Linux Ubuntu in a VirtualBox. I have installed a LAMP server on Ubuntu but I am not sure how to access it. Right now I have my router set up to Port forward to my IP but that IP is only good for my HOST computer. Is there a way to forward to my Virtualized Guest OS?

share|improve this question

closed as off topic by Sven, Iain Oct 5 '12 at 10:15

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Your question is off topic for Serverfault because your question isn't about a professional server/networking/desktop support environment. It may be on topic for Superuser but please search their site for similar questions that may already have the answer you're looking for. – Iain Oct 5 '12 at 10:15… – Iain Oct 5 '12 at 10:23
up vote 2 down vote accepted

In Virtualbox's settings, set the machine to have a Bridge Network adapter. That means that your guest will have a proper IP address on your network and will not simply use NAT through the host. Then you can set your router to forward the port to the guest's IP.

share|improve this answer
thanks thats what I needed! – JasonDavis Oct 5 '12 at 23:45

The default networking mode for Virtualbox is NAT. You can either configure Port forwarding in Virtualbox (as well as on your router) or using bridge mode networking where your VM guest is connected directly to the network.

See Virtual networking

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.