Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

My new v2.2.10 postfix server seems to be working well. But it is always logging "postfix/smtp[2095]: discarding EHLO keywords: 8BITMIME"

Is this good, bad or indifferent? [Why shouldn't the server handle 8BITMIME?]

I think I'd like to suppress the log messages. I found http://www.postfix.org/postconf.5.html#smtp_discard_ehlo_keywords

Is this the right thing to do? Can you give me an example of using that config parameter correctly?

Thank you for your expertise!

Larry

share|improve this question

2 Answers 2

up vote 1 down vote accepted

The usual reason to discard the 8BITMIME ESMTP keyword is to make sure things that depend on 7-bit clean message bodies work properly. The most obvious example is DomainKeys/DKIM signing. If your message is signed as an 8-bit message and later downgraded to 7-bit by a downstream hop, signatures will break as content is converted to Quoted-Printable (or less likely, Base64).

Forcing the upstream hop to convert to Quoted-Printable before delivering to your Postfix server (i.e., not advertising 8BITMIME in the EHLO response) is the easiest way to get a clean message for your content scanning/signing stuff. At a guess, if this was in your distribution's default main.cf, the packager wanted to make sure you had a lowest-common-denominator setup with no nasty surprises when you add features later on.

In general, trying to get Postfix not to log stuff is more trouble than it's worth. Better to post-process the logs via scripts (or in your syslog daemon if it has the capability).

share|improve this answer
    
So I should leave the conf as it is and not turn on 8bit mime? Thanks. –  LarryK Aug 5 '09 at 14:34
    
It doesn't hurt to leave it as is, and it's one less thing to remember/troubleshoot if you add features that need 7-bit clean content later, so I'd be inclined to leave it. And as Devdas said, include the pseudo-keyword "silent-discard" in your smtp_discard_ehlo_keywords if you want to suppress logging. –  Rob Chanter Aug 7 '09 at 5:24

When reporting a Postfix problem (or even just asking a question), please follow the instructions in Debug Readme .

As I understand it, you have setup smtp_discard_ehlo_keywords without actually using the silent-discard pseudo keyword in the values. I would suggest not modifying these options unless you know what you are doing.

Also, modify your log parsing script(s) to ignore that line in your logs. Far easier.

share|improve this answer
    
A rather unhelpful response. I'm asking you what should I do! –  LarryK Aug 5 '09 at 14:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.