Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have an application installed in my RHEL6 box that has a GUI ( My problem is that a few non-tech users would like to access this GUI remotely. I've tried several guides over the internet but I still cant make it work.

I tried: -Installing X Window System -Enabling FORWARDX11=yes in my sshd_config -Exporting $DISPLAY variable -Connecting through ssh -X user@host (simply stays there)

How can I setup my box from scratch to make this work?

share|improve this question
up vote 3 down vote accepted

You could do this the easy way with NoMachine (NX). It's basically compressed X11 over SSH. So all you'll need on the remote side is a client (Mac, Windows, Linux) and to install a server piece on the RHEL6 box you're trying to connect to.

Anything else if going to be a bit slow (raw X11 forwarding), choppy (VNC) or a pain to setup (what you're going through now).

share|improve this answer
Ok will try this now and Ill let you know. – Rhyuk Oct 5 '12 at 13:17
Ugh... its giving me errors at the start session... Oct 5 09:59:06 isvahlrtk01 NXSERVER-3.5.0-11[53330]: ERROR: (exception id 5B3926AB) NX> 596 ERROR: execution of last command failed Oct 5 09:59:06 isvahlrtk01 NXSERVER-3.5.0-11[53330]: ERROR: (exception id 5B3926AB) NX> 596 last command: /usr/bin/xauth -v -f /home/tkadmin/.nx/C-isvahlrtk01-1004-A4C27A6B9F9A3BA43DECD3703AF73C9B/authority source /home/tkadmin/.nx/C-isvahlrtk01-1004-A4C27A6B9F9A3BA43DECD3703AF73C9B/scripts/au‌​thority – Rhyuk Oct 5 '12 at 14:02
Ok found the solution for that problem. You need to add your hostname to /etc/hosts like this " localhost.localdomain localhost my_simple_hostname_here" now to deal with another error. Will keep you posted. – Rhyuk Oct 5 '12 at 14:10
@Rhyuk Your /etc/hosts should follow these guidelines. – ewwhite Oct 5 '12 at 14:16
Good News! Got it working! Bad news, theres a known bug with gnome desktop. Only loads background and the CTRL+ALT+R workaround doesnt work for me :/ – Rhyuk Oct 5 '12 at 14:41

The easiest way for me is to use MobaXterm: you just have to

You have nothing else to do: MobaXterm automatically starts an X11 server and uses X11-Forwarding to display your remote GUI app. This is done without any need for further configuration, so it is very easy.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.