Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a basic Atcom IP01 with the following config

  1. Registered Voip (SIP) Trunk
  2. Registered Voip Phone - ext
  3. Dial Plan
  4. Outbound Call rule

I made use of this manual that the manufacturer supplies:

http://www.atcom.cn/cn/download/pbx/ip01/ATCOM%20IP01-User%20Manual-V1.0-EN.pdf

Whenever I try and make a call, it seems that the outbound call rule that i defined does not get regarded as the default rule even though the dial plan lists this as the only outbound call rule.

When dialling I see in the log file the following

[Jan 1 09:10:07] NOTICE[176]: chan_sip.c:14377 handle_request_invite: Call from '6001' to extension '00765243679' rejected because extension not found.

The 00765243679 is a cellular number.

Am I missing a configuration in order to make outbound calls? Land line, other Voip numbers and cellular calls have been tried

share|improve this question
    
Could you add the relevant portion of extensions.conf, at least the outbound call rule(s). And your asterisk version. –  Koos van den Hout Oct 6 '12 at 14:44
add comment

1 Answer

up vote 3 down vote accepted

You need to setup an extension that uses matching to match your local telecom rules. I'm only familiar with the US rules so I'll use them as an example.

To dial a local number in the US you would setup an extension that looks like:

exten => _9NXXXXXX,1,Dial(${GLOBAL(TRUNK)}/${EXTEN:${GLOBAL(TRUNKMSD)}})

What this does is:

  • Tell it it is a matching extension _
  • tell it to match only 9 for outbound (the dial out prefix - 9 is the custom in the US)
  • Tell it to then match any number in the NPA NXX format
  • Send the call out of the configured Trunk

There is alot of good Asterisk configuration information at http://voip-info.org

share|improve this answer
    
I have done this. My prefix is 0. And the "_" is there. Still unable to make outbound calls. What is the N in your config for? –  deanvz Oct 19 '12 at 14:54
    
This worked for me. I made a mistake by doing the following, _9XXXXXXXXXX. the full stop was the wildcard that caused my dial pattern on the phone to not work –  deanvz Nov 3 '12 at 11:30
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.