Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a weird problem with my server. The server is inside my network, connected to a 3com switch which is connected to the router that handles the internet connection. The main purpose of the server is to host a php application.

What's happening is that user 1 to 15 in the private network have no problems connecting to the server, when user 16 tries to connect a time out comes out and is unable to connect to the server. It's not just to the php application, but to any service from the server. When the 15 users are using the application, the server doesn't even answer to ping.

I haven't set any special limit in Apache's ini file or MySql and the firewall is being turned off because the server is only to give service to the internal network. Is there a parameter in any of the network's card conf. files that might me causing this ? Or should I suspect from the router's or switches configuration ?

UPDATE. Tomorrow, I'm gonna do some test on the server modifying two kernel params in :

/etc/sysctl.conf

The settings are:

    net.core.somaxconn 

which has the limit on simultaneous network connections to the server and

    kernel.shmmax

which controls the amount of memory the system can use for managing connections.

share|improve this question

migrated from stackoverflow.com Oct 5 '12 at 22:35

This question came from our site for professional and enthusiast programmers.

    
It's probably the router. Whether or not you will be able to do anything about it without getting a different router is the big question. –  Wug Oct 5 '12 at 17:20
    
Thanks Wug... unfortunately I can't manage the router, but I'm also thinking of it as my prime suspect... The router is managed by my ISP... –  Luis M. Valenzuela Oct 5 '12 at 17:25
    
I've keep doing further readings, and it seems that maybe there's a chance that some kernel settings maybe limiting the number of connections. The settings are: kernel.shmmax and net.core.somaxconn Both in /etc/sysctl.conf –  Luis M. Valenzuela Oct 9 '12 at 0:46
    
If users and the server are both inside your network, the router should not be involved. Can you verify this is true? What are the internal IP addresses? –  Skaperen Oct 9 '12 at 2:02
    
Skaparen, you're right, both users, and server are inside the network. The internal IP address is in the subnet of 192.168.1.xxx, mask 255.255.0.0 and the gateway is also in the subnet of 192.168.1.xxx. –  Luis M. Valenzuela Oct 9 '12 at 13:28
add comment

1 Answer

As you might guess this problem was due to the network topology. The network is installed in a school, and it has the weirdest topology I've seen so far. They've got a dedicated broadband internet access managed by a CISCO router. They also have a second internet access (ADLS) managed by the cheapest router you might find in the market. This second access is used to "distribute" the internet load (????). The router is not configured as a DHCP server, so in every classroom they have Apple's Airports to provide a WIFI connection, but also the Airports weren't configured as DHCP servers.

For ever kid, teacher and user in the school the network manager assigned a static IP address and has been configured in each computer, some of them, use the ISDN internet access and some the ADSL. So you might guess the nightmare...

The solution:

  1. Configure the apple's airports to provide DHCP, and configure again, each kid's computer to obtain the address from the airport.
  2. Configure the apple's airport so the airport itself is in the same network as the server.

And that was it.... Thanks a lot to every one who helped me giving me clues.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.