Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I know from dnsmasq's man page that it is capable of handling mx records, but I can't seem to find anything in pfsense's web GUI or anywhere online that talks about how to include mx records.

I'm running pfsense 2.0.1 on a turnkey hardware appliance. I have root shell access.

I would prefer not to move away from using DNS Forwarder/dnsmasq if I can help it.

I've searched for a dnsmasq.conf file, but none exists. pfsense handles everything through a centralized xml config file. That file merely designates the dnsmasq section using the tag, then drops immediate into listings for each host override you define.

My understanding of pfsense's implementation: In the GUI, you can only define an override using the host, domain, IP and description. In the XML that translates to:

<hosts>   
  <host>foo</host>
  <domain>foo.com</domain>
  <ip>127.0.0.1</ip>
  <descr/>
</hosts> 

The above example results in foo.foo.com resolving to 127.0.0.1, for instance.

But that's it. No ability to select a record type with which to define things like MX.

Anyone had any luck with this?

Thank you for any insights you might have.

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

Generally no need for that, as being a full blown DNS server is usually done elsewhere and host overrides suffice. You can use the --mx-host syntax for dnsmasq in the advanced options box if you really need that. Described in the dnsmasq man page. http://www.thekelleys.org.uk/dnsmasq/docs/dnsmasq-man.html

share|improve this answer
    
Chris, thanks for the feedback. I'll check into this and let you know. I think we're going to move our MX records off, so you're right. It wouldn't be needed. That said, great to know about the argument option in advanced options. I'd normally PM you this part of my response, but I'm still too new to SF. Anyway, strangely, you and I share the same last name. Spelled the same too. Bizarre! –  Bob B. Oct 8 '12 at 22:54
    
huh, bizarre indeed. Well you're using the right firewall for sure, I'm the co-founder of pfSense. :) –  Chris Buechler Oct 9 '12 at 7:13
    
Hi Chris, just wanted to get back to you on this. That indeed solved my issue. Thank you for your help! (I'd upvote, but I don't yet have the required SF reputation.) –  Bob B. Oct 18 '12 at 14:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.