Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying out a request-tracker installation on an EC2 micro instance. The specs for the micro instance are as follows

1) Ubuntu 12.04 64bit, 613MB RAM, 8GB Hard Drive

2) Running request-tracker 4.0.4 from the repository, perl 5.14.2, Apache2, MySQL5

3) Request-tracker4.0.4 running with mod_perl2 and Worker mpm

4) Apache configured with Worker MPM. Config snippet given below

Timeout 150
KeepAlive On
MaxKeepAliveRequests 60
KeepAliveTimeout 2

<IfModule mpm_worker_module>
     StartServers          2
     MinSpareThreads      25
     MaxSpareThreads      75
     ThreadLimit          64
     ThreadsPerChild      25
     MaxClients          150
     MaxRequestsPerChild   0
</IfModule>

Now when I start Apache2 it works fine for some time and after a while the CPU load shoots up to 99% or more. Usually it is one or more Apache processes doing this. I've tried a to modify the worker module configuration without any luck.

The log files for both Apache2 and request-tracker4 are set to log debug messages and don't show anything to indicate what could be causing this.

The system gets a maximum of 5 users at any given time and usually (90% of the time) it is just 2. I've just installed it and we only have 20 tickets in the database.

I don't think its the memory thats causing the issue since the server isn't swapping or even close to it and I hardly see the memory usage go up.

Would appreciate any pointers on how to go about troubleshooting this.

In case it helps I've also tried this out a similar installation on a small instance (Identical settings except RAM bumped upto 1.7GB) and I still see the issue.

share|improve this question
    
Is request-tracker thread-safe? Maybe try prefork instead of worker. –  Shane Madden Oct 6 '12 at 20:21
    
It is meant to be. I'll try it with prefork and see if that changes anything. Thanks. –  bhowmik Oct 8 '12 at 13:58
    
Hi, did you find a config for apache or RT that reduced the system usage? For me, RT runs decently, but sending mails fails. 'sendmail' says out of memory. –  Aswin Kumar Jul 21 '13 at 14:07
    
I ended up using prefork mode. It did resolve the initial issues that I was facing. My current usage has gone up with an additional user and close to about a 1000 tickets now and its still able to cope with the load with the occasional hiccup. Never had a problem with Sendmail though. Take a look at MAX_DAEMON_CHILDREN for sendmail maybe that will help you. –  bhowmik Jul 23 '13 at 9:10

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.