Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

During my Nconf install I get

Requirements

PHP 5.0 (or higher) -> 5.3.10-1ubuntu3.4 OK
MySQL 5.0.2 (or higher) -> 5.5.24 OK
PHP-MySQL support OK
Perl 5.6 (or higher) -> FAILED

But when I check

perl -v 

This is perl 5, version 14, subversion 2 (v5.14.2) built for i686-linux-gnu-thread-multi-64int

share|improve this question

1 Answer 1

up vote 0 down vote accepted

This is because of the way install.php gets the version :

Take a look at INSTALL.php

function find_PERL_Version() { (line 316)
        $output = shell_exec('perl -v');
       [...]
        preg_match('/is perl, v([0-9]+[\.0-9]*)/i', $output, $version);

This script is expecting this kind of syntax :

'This is perl, v5.nn.mm' (eg v5.10.0).

Your perl application returns

'This is perl 5, version 14, subversion 2 (v5.14.2)'

A possible workaround (based on your configuration) is to replace the preg_match :

preg_match('/v([0-9]+[\.0-9]*)/i', $output, $version);

Function will then return the correct version (5.14.2) and you will be able to continue the install.

share|improve this answer
1  
Awesome! Just tried this and it works. Thank you, Now I can finish my install. –  Jake Oct 15 '12 at 7:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.