Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to follow the steps from the MigrationGuide (modified to reflect the fact I'm dealing with non-current versions) to migrate from RHEL 5.1 to CentOS 5.1. I used the following commands:

# rpm -e --nodeps redhat-release-notes redhat-release yum-rhn-plugin redhat-logos
# rpm -ivh http://vault.centos.org/5.1/os/x86_64/CentOS/centos-release-5-1.0.el5.centos.1.x86_64.rpm http://vault.centos.org/5.1/os/x86_64/CentOS/centos-release-notes-5.1.0-2.x86_64.rpm
# yum update

This fails on the yum update step with an error claiming there's a conflict between e2fsprogs and the kernel. I've included a more detailed error below.

# yum -d7 upgrade kernel
Loading "installonlyn" plugin
Running "config" handler for "installonlyn" plugin
Yum Version: 3.0.1
COMMAND: yum -d7 
Installroot: /
Ext Commands:

   kernel
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Setting up Package Sacks
Reading Local RPMDB
Building updates object
Resolving Dependencies
1248192166.57
--> Populating transaction set with selected packages. Please wait.
Member: kernel.x86_64 0-2.6.18-128.2.1.el5 - u
kernel - 2.6.18-128.2.1.el5.x86_64 converted to install
Adding Package kernel - 2.6.18-128.2.1.el5.x86_64 in mode i
---> Package kernel.x86_64 0:2.6.18-128.2.1.el5 set to be installed
--> Running transaction check
# of Deps = 1

Dep Number: 1/1

--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
TSINFO: Updating e2fsprogs - 1.39-20.el5.x86_64 to resolve conflict.
miss = 0
conf = 0
CheckDeps = 1
--> Restarting Dependency Resolution with new changes.
---> Loop Number: 2
Restarting Loop
--> Populating transaction set with selected packages. Please wait.
Member: kernel.x86_64 0-2.6.18-128.2.1.el5 - i
Member: e2fsprogs.x86_64 0-1.39-20.el5 - u
Adding Package e2fsprogs - 1.39-20.el5.x86_64 in mode u
---> Package e2fsprogs.x86_64 0:1.39-20.el5 set to be updated
--> Running transaction check
# of Deps = 3

Dep Number: 1/3

--> Processing Conflict: kernel conflicts e2fsprogs < 1.37-4
Error: No Package Matching kernel.x86_64
share|improve this question
    
Just a question: are you updating from the x86_64 version of RHEL 5.1? –  HD. Jul 21 '09 at 16:27
    
Yes. I almost upgraded x86_64 to i386 but caught my mistake just in time. –  Hank Gay Jul 21 '09 at 16:37

2 Answers 2

up vote 3 down vote accepted

Check if the 32 bit version (i386,i586,i686) of e2fsprogs exists in your system and remove it if you don't need it.

share|improve this answer
    
On a similar note, I found this bug report: bugs.centos.org/view.php?id=1962 –  Hank Gay Jul 21 '09 at 17:15

As HD says, there's a known bug in older versions of yum that if there is 2 or more conflicts ona single package yum will fix the first one and then bail on the second (here conflicts for both .i?86 and .x86_64 count one each).

You can either get a beta version of yum for 5.4, or remove one of the arches ... or manually update e2fsprogs as well (so there is no conflict).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.