Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Quad-core/8GB Vista Enterprise 64-bit (SP2) installation on which I installed Virtual PC 2007.

I have a problem that is opposite of all that I found searching around the Internet--everybody has problems making network connections from their guest VM.

When Virtual Machine Network Services is enabled in the protocol stack for my network card across a reboot, it causes access problems to the network. The amount of time to login in using a domain credentialed account is upwards of 3 minutes, then after reaching the desktop the network and sharing center shows that my connection to the domain is unauthenticated.

Disabling and re-enabling the Virtual Machine Network Services (uncheck in network properties/apply/recheck/apply) fixes the problem. And as long as I have the VMNS disabled when I shutdown the restart runs smoothly. I just have to remember to enable after login and disable before shutdown.

I have un-installed and re-installed Virtual PC 2007 multiple times with restarts between. The install consists of the SP1 + a KB patch for guest resolution fix.

Any help would be greatly appreciated.

Some additional information...

At one point during my hairpulling and teethgnashing with this, I tried to ping my primary DC and observed some weird responses: (Our DC is, my dynamic IP was

Reply from, Destination host unreachable.
Request timed out.
Reply from ...

This is not consistently repeatable, but thought it might strike a chord with someone.

share|improve this question

I've no experience with VPC 2007 in this capacity, but from the sounds of it, it sounds very much like a DNS issue. That's usually what causes large delays in login time.

share|improve this answer
There is some credence to what you say based on other things I have seen, but I feel the problem is further down the stack and that DNS related issues are symptoms and not the cause. – Bill Jul 23 '09 at 3:16
That certainly sounds plausible – Mark Henderson Jul 23 '09 at 3:58

Is there anything out of gthe oridinary about your network (NAP, QOS, Tagged VLANS). Virtual Machine Network Services just gives the VM's access to dump their packets to the wire from what I can tell.

share|improve this answer
The QOS component in the network stack is on by default, as well as the IPv6 components. I have tried disabling these items but it does not change the behavior. – Bill Jul 23 '09 at 3:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.