Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I got a new vps from x10vps (x10hosting) and set up the domain via cloudflare.

This is what the email looks like:

Delivered-To: xxx@gmail.com
Received: by 10.64.19.240 with SMTP id i16csp357708iee;
        Tue, 9 Oct 2012 01:29:48 -0700 (PDT)
Received: by 10.50.57.130 with SMTP id i2mr908846igq.56.1349771387599;
        Tue, 09 Oct 2012 01:29:47 -0700 (PDT)
Return-Path: <xxx@chvw.de>
Received: from power.SOURCEAPE.COM ([198.91.90.116])
        by mx.google.com with ESMTPS id v8si25630942ica.46.2012.10.09.01.29.46
        (version=TLSv1/SSLv3 cipher=OTHER);
        Tue, 09 Oct 2012 01:29:47 -0700 (PDT)
Received-SPF: temperror (google.com: error in processing during lookup of xxx@chvw.de: DNS timeout) client-ip=198.91.90.116;
Authentication-Results: mx.google.com; spf=temperror (google.com: error in processing during lookup of xxx@chvw.de: DNS timeout) smtp.mail=xxx@chvw.de
Received: from nk11p03mm-asmtp010.mac.com ([17.158.232.169]:54276)
    by power.SOURCEAPE.COM with esmtp (Exim 4.80)
    (envelope-from <xxx@chvw.de>)
    id 1TLVBD-0004Ig-1Y
    for xxx@chvw.de; Tue, 09 Oct 2012 12:28:43 +0400

I then tried to enable SPF and DKIM and got following massage

In order to ensure that SPF or DKIM takes effect, you must confirm that this server is an authoritative nameserver for chvw.de. If you need help, contact your hosting provider.

Status: Enabled Warning: cPanel is unable to verify that this server is an authoritative nameserver for chvw.de. [?]

and the email header now looks like this:

Delivered-To: xxx@gmail.com
Received: by 10.50.183.227 with SMTP id ep3csp14506igc;
        Tue, 9 Oct 2012 01:55:23 -0700 (PDT)
Received: by 10.50.40.133 with SMTP id x5mr992934igk.32.1349772923717;
        Tue, 09 Oct 2012 01:55:23 -0700 (PDT)
Return-Path: <xxx@chvw.de>
Received: from power.SOURCEAPE.COM ([198.91.90.116])
        by mx.google.com with ESMTPS id ng8si25688859icb.42.2012.10.09.01.55.23
        (version=TLSv1/SSLv3 cipher=OTHER);
        Tue, 09 Oct 2012 01:55:23 -0700 (PDT)
Received-SPF: temperror (google.com: error in processing during lookup of xxx@chvw.de: DNS timeout) client-ip=198.91.90.116;
Authentication-Results: mx.google.com; spf=temperror (google.com: error in processing during lookup of xxx@chvw.de: DNS timeout) smtp.mail=xxx@chvw.de; dkim=neutral (bad format) header.i=@chvw.de
DKIM-Signature: v=1; a=rsa-sha256; q=dns/txt; c=relaxed/relaxed; d=chvw.de; s=default;
    h=Message-ID:Subject:To:From:Date:Content-Transfer-Encoding:Content-Type:MIME-Version; bh=iugsx3Lx0KnqjR7dj3wyQHnJ9pe/z3ntYEVk80k8rx4=;
    b=IrYsCtHdoPubXVOvLqxd7sLE/TyQTS5P3OrEg5SSUSKnQQcQ/fWWyBrmsrgkFSsw6jCmmRWMDR09vH5bQRpFPMA57B7pf8QRKhwXOWFBV+GnVUqICsfRjnNPvhx/lNp5;
Received: from localhost ([127.0.0.1]:46539 helo=direct.chvw.de)
    by power.SOURCEAPE.COM with esmtpa (Exim 4.80)
    (envelope-from <xxx@chvw.de>)
    id 1TLVb0-0004dZ-Kd
    for xxx@gmail.com; Tue, 09 Oct 2012 12:55:22 +0400
share|improve this question

3 Answers 3

I can't speak to the DKIM, but you don't seem to have any SPF records:

[me@risby ~]$ dig txt chvw.de

; <<>> DiG 9.8.3-P3-RedHat-9.8.3-4.P3.fc16 <<>> txt chvw.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64092
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;chvw.de.           IN  TXT

;; AUTHORITY SECTION:
chvw.de.        10631   IN  SOA bob.ns.cloudflare.com. dns.cloudflare.com. 2012092713 10000 2400 604800 3600

So when you say you enabled SPF, what exactly did you do? Getting working SPF records would definitely be a good start.

share|improve this answer

Most of those listings shouldn't be an issue with Spamhaus now. If the user was missing TXT/SPF records in their zone file, they should add the records in their CloudFlare DNS settings (settings->DNS settings).

share|improve this answer

"and set up the domain via cloudflare".

that could be your problem. chvw.de's A and NS ips are both blacklisted at spamhaus.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.