Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have been struggling with this for more than 5 hours now, and I can't seem to find the fix to my problem. Basically, I set up virtual host on my Fedora Core server (on custom port 55555). Any time I try to access php files by typing in browser for example 111.111.111.111:55555/somefile.php browser forces this file to download. I want php files to be parsed.

The following is my httpd.conf appended part:

Listen 55555

<VirtualHost *:55555>
    DocumentRoot "/var/www/vhosts/example.com/httpdocs/app/"
    ServerName 111.111.111.111:55555
    CustomLog "/var/log/app/access.log" combined
    ErrorLog "/var/log/app/error.log"

    <Directory "/var/www/vhosts/example.com/httpdocs/app/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory> 
</VirtualHost>

Anyone has clue why the php files are forced to download and how to parse them?

Well, the point is that when I set up domain under plesk php files are parsed without any problem.

In httpd.conf there are only 3 lines referring to php configuration:

DirectoryIndex at_domains_index.html index.html index.html.var index.shtml index.cfm index.php index.htm index

AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

In conf.d folder in php.conf file I have the following content:

#
# PHP is an HTML-embedded scripting language which attempts to make it
# easy for developers to write dynamically generated webpages.
#

LoadModule php5_module modules/libphp5.so

#
# Cause the PHP interpreter to handle files with a .php extension.
#
AddHandler php5-script .php
AddType text/html .php

#
# Add index.php to the list of files that will be served as directory
# indexes.
#
DirectoryIndex index.php

#
# Uncomment the following line to allow PHP to pretty-print .phps
# files as PHP source code:
#
#AddType application/x-httpd-php-source .phps
share|improve this question

migrated from stackoverflow.com Oct 9 '12 at 12:11

This question came from our site for professional and enthusiast programmers.

    
You need to post more of your configuration file, like, the part that configures PHP. –  Dondi Michael Stroma Oct 8 '12 at 22:46
    
is the same if you disable virtual hosts and use the apache default root? –  luso Oct 9 '12 at 8:11

1 Answer 1

Fix the problem by enabling php modules. Here is how my Virtual Host configuration looks like:

Listen 55555

<VirtualHost *:55555>
    DocumentRoot "/var/www/vhosts/example.com/httpdocs/app/"
    ServerName 111.111.111.111:55555
    CustomLog "/var/log/app/access.log" combined
    ErrorLog "/var/log/app/error.log"

    <Directory "/var/www/vhosts/example.com/httpdocs/app/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>

    <Directory /var/www/vhosts/example.com/httpdocs/app>
        <IfModule sapi_apache2.c>
            php_admin_flag engine on
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/example.com/httpdocs/app:/tmp"
        </IfModule>
        <IfModule mod_php5.c>
            php_admin_flag engine on
            php_admin_flag safe_mode on
            php_admin_value open_basedir "/var/www/vhosts/example.com/httpdocs/app:/tmp"
        </IfModule>
        </Directory> 
</VirtualHost>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.