Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've configured my Raspberry Pi to use "dash" for default shell, as instructed here.

I have Dropbear for SSH.

When I login via SSH, I still see the "bash" console, and not "dash".

How to change this and forget bash?

share|improve this question

closed as off topic by SvW, Michael Hampton, EightBitTony, Iain Oct 21 '12 at 20:30

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
It's a useful question but strictly speaking is off-topic. –  EightBitTony Oct 9 '12 at 21:54
    
Your question is off topic for Serverfault because it doesn't appear to relate to servers/networking or desktop infrastructure in a professional environment. It may be on topic for unix but please search their site for similar questions that may already have the answer you're looking for. –  Iain Oct 21 '12 at 20:29

2 Answers 2

up vote 6 down vote accepted

Try the following command line :

chsh -s $(type -p dash)
share|improve this answer
1  
I'd run type -p dash first, just to be certain the system can find it. You don't want to risk setting your default shell to an error message. (Ok, it wouldn't actually do that, but still.) –  Keith Thompson Oct 9 '12 at 21:49

type dash that should do it, but really you should use chsh and change shell permanently

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.