Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Right now my localhost path is limited to C:\inetpub\wwwroot. I am using IIS 7.5 and would wish to start working on PHP. before enabling the IIS 7, I was unable to connect to localhost/ Now, it can connect and display files but I cannot link a workspace to that folder. Is there a way for me to change/edit the physical path for the localhost to source to?

enter image description here



share|improve this question

migrated from Oct 10 '12 at 1:59

This question came from our site for professional and enthusiast programmers.

You might be better posting this on ServerFault. – slugonamission Oct 9 '12 at 22:40
up vote 1 down vote accepted

Open up the IIS configuration manager (or something like this, I can't remember the name) in, control panel -> administrative tools.
You can edit/create your local websites there.

share|improve this answer
Thank you for this! – Legend Oct 10 '12 at 0:44

If you want to create a different ISS webroot all you neeed to do is change the properties of the default website as this will simply be C:\inetpub\wwwroot.

Keep in mind that the PHP.ini will also need to be amended should you wish to change your webroot.

If however you wish to work on one project, you can create a website by right clicking within the right hand menu and choosing new website. The wizard will provide you the ability to customise the settings for one self contained site, one parameter is the root of the website it self e.g C:\inetpub\wwwroot\mysite1. You can have many websites using the same site folder.

You will also want to make sure IIS is configured for .php files. Take a look at the FastCGI module for IIS.

share|improve this answer
Thanks for this, I ended up following the other guy's instructions but you did help get it started too :) – Legend Oct 10 '12 at 0:45

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.