Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

By mistake I entered an iSCSI target portal address in the iSCSI Initiator on one of our virtual servers that does not have an address in the network range used for iSCSI. This caused the following errors/warnings to appear in the eventlog:

Log Name:      System
Source:        MSiSCSI
Event ID:      113
Level:         Warning
Description:
iSCSI discovery via SendTargets failed with error code 0xefff0003 to target
portal *192.168.23.42 0003260 Root\ISCSIPRT\0000_0 .

Log Name:      System
Source:        iScsiPrt
Event ID:      1
Level:         Error
Description:
Initiator failed to connect to the target. Target IP address and TCP Port
number are given in dump data.

Log Name:      System
Source:        iScsiPrt
Event ID:      70
Level:         Error
Description:
Error occurred when processing iSCSI logon request. The request was not
retried. Error status is given in the dump data.

So far that's expected beahvior, so I removed the portal from the iSCSI Initiator as described in MSKB 976072. However, the errors/warnings keep appearing every hour, even though neither iSCSI Initiator GUI nor iscscli show any portals (or iSNS servers):

C:\>iscsicli ListTargetPortals
Microsoft iSCSI Initiator Version 6.1 Build 7601

The operation completed successfully.

C:\>iscsicli ListiSNSServers
Microsoft iSCSI Initiator Version 6.1 Build 7601

No iSNS Servers
The operation completed successfully.

The problem persists after rebooting the server. Uninstalling the Microsoft iSCSI Initiator device via devmgmt.msc as well as changing the Initiator parameters like this:

[HKLM\SYSTEM\CurrentControlSet\Control\Class\{4D36E97B-E325-11CE-BFC1-08002BE10318}]
"MaxPendingRequests"=dword:00000001
"MaxConnectionRetries"=dword:00000001
"MaxRequestHoldTime"=dword:00000005

didn't help either. Each change was followed by a reboot.

Disabling the device does prevent the errors/warnings from re-appearing, of course, but I'd rather not have to resort to this.

How can I prevent those errors and warnings from appearing (short of disabling the initiator device or re-installing the server)? What am I missing?

Environment: The virtual machine runs on a Hyper-V cluster managed by SCVMM 2012. Hosts and guests run Windows Server 2008 R2 SP1. The physical machines are Dell PowerEdge M710HD blades.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted
+50

Strange and does not reproduce here.

I understand stopping/disabling the service is also not an option? If you temporarily net stop msiscsi, does this stop the hourly events?

As a wild guess try to see if the address didn't end up also as an iSNS server, which would have a very similar effect:

iscsicli ListiSNSServers

Also review the entire [HKLM\Software\Microsoft\Windows NT\CurrentVersion\ISCSI\Discovery] for any unexpected keys (more here http://blogs.msdn.com/b/san/archive/2008/07/27/microsoft-iscsi-software-initiator-isns-server-timers-quick-reference.aspx).

share|improve this answer
    
Thanks for your response. No, there are no iSNS servers (I updated the question with the command output). I didn't check with iscsicli before, but I'm positive that none were listed in the GUI. Also there aren't any values in the Discovery key or its subkeys. The issue seems to have resolved itself, though. Since yesterday evening around 19:00 no further events were recorded, so perhaps it just needed an expanded period of time to run into a timeout. I'm accepting your answer anyway, if only for the quick reference. Thanks again. –  Ansgar Wiechers Oct 23 '12 at 15:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.