Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server which I'd like to install Ubuntu 12.04 on, but I've had some problems and thought it would be nice to get things working in a Virtualbox VM with the same features as the server.

I want to enable UEFI-boot in the VM. I "Enable EFI" in the System / Motherboard settings for the VM.

System settings for the Virtualbox VM

I make sure the Ubuntu Server 12.04 ISO is inserted when I boot.

The CD/DVD device has the Ubuntu Server 12.04 ISO inserted in the Virtualbox VM when booting it

And yet I get stuck in the UEFI boot console when I start the VM.

enter image description here

How do I install Ubuntu Server 12.04 in a UEFI boot-enabled Virtualbox machine?

share|improve this question
    
Just out of couriosity: Why do you want to use EFI Boot? –  Christopher Perrin Oct 10 '12 at 16:35
    
I want the VM to be as similar to my server hardware as possible. It's easier to perform trail and error in a VM with snapshots than on the real server hardware. –  Deleted Oct 10 '12 at 16:48
    
I've read all threads related to UEFI on the forums for Virtualbox. People keep citing the manual which states that EFI support is experimental. I have not been able to find any thread with any success report. Just for term usage: EFI is Intels specification, and UEFI is the open one based on EFI. In reality, as far as I've been able to tell from reading, we can treat them as the same thing for now. –  Deleted Oct 11 '12 at 23:29
add comment

2 Answers

If you are getting to the EFI shell you likely already installed Ubuntu in EFI mode. The caveat I have found it that thought the OS installs fine using the grub-efi bootloader, an EFI boot entry for that boot loader is not written into the EFI variables correctly. This means the EFI firmware does not know how to load the boot loader and thus the OS and drops into the shell. See if you can load the boot loader and the OS from the shell:

fs0:

cd EFI/ubuntu

grubx64.efi

If this works that is definitely your issue (and mine). Supposedly the installed efibootmgr and can set this up for you but evidently is it confused in this release as it requires efivars and wants you to load this as a kernel module but in 12.04 kernels this is monolithically compiled in (meaning always in the kernel and not as a module) so it fails with an error message telling you to "modprobe efivars".

share|improve this answer
add comment

For whom have tried below, but not success.

fs0:

cd EFI/boot

grubx64.efi

Check your virtualbox setting, General > Basic > Version.

If it read "Ubuntu", change to "Ubuntu (64bit)" and boot again. Then you should boot into grub not EFI shell.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.