Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem with my server's httpd service. When I try to start it, it returns the following error:

Starting httpd: Syntax error on line 28 of /usr/local/directadmin/data/users/dnsbeheer/httpd.conf:
Invalid command 'RMode', perhaps misspelled or defined by a module not included in the server configuration

The server is running DirectAdmin Control Panel.

Does anyone know how to fix this?

share

locked by HopelessN00b Apr 3 at 17:32

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off-topic by HopelessN00b Apr 3 at 17:31

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Grep the file for RMode figure out why that is broken, and fix it. –  Zoredache Oct 10 '12 at 17:11
    

2 Answers 2

up vote 1 down vote accepted

The error indicates that Apache doesn't understand the "RMode" command. This means that the module that implements it either wasn't included in your configs or failed to load. Search your configs for the module that provides RMode to make sure it's being loaded and if it's in a config other than httpd.conf, make sure it's being included by httpd.conf (like files in conf.d tend to be.)

share

RMode is part of mod_ruid if you are using mod_ruid then make sure Apache is loading it. Depending on were you added the module to load then Direct Admin might have overwritten your changes when if it was told to rewrite the HTTP config.

If you are not using mod_ruid then you might need to check /usr/local/directadmin/data/users/dnsbeheer/httpd.conf for any config which is referring to mod_ruid looks like the following

    <IfModule mod_ruid2.c>
            RMode config
            RUidGid user user
            RGroups apache access
    </IfModule>

if it doesn't then you will need to correct the virtual_host templates in /usr/local/directadmin/data/templates and rewrite the configs

share

Not the answer you're looking for? Browse other questions tagged or ask your own question.