Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I got a ubuntu server running redmine from apache.

My clients, can access redmine, but stops responding random, and other clients, can browse redmine fine, when the client with the problem cant browse the page.

In tcpdump i see the request come in, but nothing goes back to the client, its the same with icmp packges

I have tried to ping the other way (server -> client) and it the client returns a response.

Has anyone a solution or some experiences with that problem?

share|improve this question
    
I've seen something similar occur on my gateway at home. That was related to routes being created, so certain targets became nullrouted. Is there any chance the server is doubling as a network proxy/gateway? –  Kvisle Oct 10 '12 at 19:51
    
To explain it further; This can occur if the server gets an ICMP redirect package, but the corresponding route does not reside on the same subnet as the server itself. You can turn off ICMP redirects in sysctl.conf. I hope your problem is this simple. –  Kvisle Oct 10 '12 at 19:57
    
Its only function is to host Redmine. Its behind a router, so its not the problem - Thanks anyway :) –  dunston Oct 10 '12 at 20:52
add comment

1 Answer 1

Tried to restart the network-interfaces, and it worked, but stopped working after a couple of days.

Made a dist-upgrade, and it seems to work, without any errors now.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.