Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Okay so I've tried stopping/registering the win32tm service on this Windows Server 2008 Enterprise Computer.

C:\Users\Administrator>net stop w32time
The Windows Time service is stopping.
The Windows Time service was stopped successfully.

C:\Users\Administrator>w32tm /unregister
The following error occurred: Access is denied. (0x80070005)

C:\Users\Administrator>w32tm /unregister
W32Time successfully unregistered.

C:\Users\Administrator>w32tm /register
W32Time successfully registered.

C:\Users\Administrator>net start w32time
The Windows Time service is starting.
The Windows Time service was started successfully.

(Source :

And I get this error from the Date and Time, Internet Time tab (After also following the steps here).


I've even tried the Atomic Time Clock Worldtimeserver and I get the error The following error occurred: The specified module could not be found. (0x8007007E).

I've also disabled the Windows Firewall, that might of been blocking the synchronization.

windows firewall

I've done a file scan with sfc /scannow that came back with no errors.

C:\Users\Administrator>sfc /scannow

Beginning system scan.  This process will take some time.

Beginning verification phase of system scan.
Verification 100% complete.

Windows Resource Protection did not find any integrity violations.


But I'm not having much luck. Is there anyway lo possibly solve this? or is the servers unsupported? because the software is from 2008? (I really don't know :/), My ping result to


Pinging [] with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.

Ping statistics for
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

And tracert result


Tracing route to [] over a maximum of 30 hops:

1 1 ms <1 ms <1 ms 2 32 ms 31 ms 32 ms []

3 31 ms 32 ms 31 ms [] 4 31 ms 31 ms 31 ms [] 5 31 ms 31 ms 30 ms [ 09] 6 167 ms 166 ms 166 ms []

7 175 ms 175 ms 175 ms [ 43] 8 177 ms 180 ms 176 ms [ 6] 9 205 ms 205 ms 204 ms [ 1] 10 * * * Request timed out. 11 * * * Request timed out. 12 * * * Request timed out. 13 * * * Request timed out. 14 * * * Request timed out. 15 * * * Request timed out. 16 ^C

And nslookup

Server:  UnKnown

Non-authoritative answer:
share|improve this question
It might be worth running Wireshark to see what's happening at the traffic level. – John Gardeniers Oct 11 '12 at 2:39
What should I be looking for? on wireshark? – Killrawr Oct 11 '12 at 2:49
Watch the NTP traffic to see how far it's getting and whether or not there are any replies, which will be ignored if they take longer than the timeout period. – John Gardeniers Oct 11 '12 at 2:55
Only you can make that assessment. However, rather than format and reinstall from scratch I would first try in in-place reinstall, which generally leaves most settings and configurations intact. Whether that's possible with Server 2008 I can't say. – John Gardeniers Oct 11 '12 at 3:03
You either misspelled in your tracert or you've got a DNS problem. If you run nslookup for does it resolve? – joeqwerty Oct 11 '12 at 3:18
up vote 4 down vote accepted

Its a little late, but you often get that error if your clock is wrong. Shockingly enough, you need to set the clock to a nearly correct time for it to synchronise properly.

Its probably so that if you DID get time related wierdness regularly , you will get off your rear and work out why its happening - its often due to a dead or weak bios battery.

share|improve this answer

Here's a better and pretty standard option... use the public NTP Pool or the USNO Master Clock for time synchronization. If you change your time clock source do you still have the same problem? Have you tried testing any external time source manually?

share|improve this answer
I've tried with,,, and they all give me timeout errors. – Killrawr Oct 11 '12 at 2:30
By the way I don't know what public NTP or USNO Master Clock, if you could provide some references? that would be nice. Regards – Killrawr Oct 11 '12 at 2:39
I've ran the command net time /setsntp:"" and w32tm /config /syncfromflags:manual /,,, and I'm still unable to sync.. :/ – Killrawr Oct 11 '12 at 2:40
If you are unable to sync with any of the public NTP servers (and assuming they resolve to valid IPs using the nameserver on your network) you have a network level issue. Check all firewalls between you and the internet (a wireshark traffic dump like John suggested in his comments on the question would be a good idea too - if the firewalls are returning the ICMP "Communication prohibited by filter" message that would tell you which firewall is saying no.) – voretaq7 Oct 11 '12 at 3:25
1 If that doesn't work, you almost certainly have a firewall problem. – Michael Hampton Oct 11 '12 at 3:33

Is this server part of a domain? It's best practice to sync from the domain environment.

Is it a Hyper-V virtual machine? If it is you need to make sure you have the "Time Synchronization" Integration service disabled.

When you run:

W32tm /query /configuration

Do you see all [local] settings? If not that may be an indicator that Group Policy is setting the time settings.

Have you tried running the commands to sync from an external time source manually?

W32tm /config /syncfromflags:manual /manualpeerlist:""
W32tm /config /reliable:yes
W32tm /config /update
Net stop w32time && Net start w32time (Alternatively, reboot if you can)
W32tm /resync /rediscover
share|improve this answer

I downloaded and it now synchronizing

share|improve this answer

protected by Michael Hampton Sep 18 '14 at 19:07

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.