Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Okay on my SharePoint server, when i want to grant a user permission to lets say the Owner's group, i go and search for the user in A.D find Him, and when i add him i get this error: Server error in '/'Application..

The same happens when i say select a user to view his permissions in SharePoint, i get the same service, also in IIS i had a look at the accounts that the application pools are using and they are a domain account with the correct rights to connect to A.D.

In event log this is the event.

Event code: 3005 
Event message: An unhandled exception has occurred. 
Event time: 10/11/2012 10:02:47 AM 
Event time (UTC): 10/11/2012 8:02:47 AM 
Event ID: d902e2fa97c9449aa7b5cc4ed017723b 
Event sequence: 2913 
Event occurrence: 5 
Event detail code: 0 


Application information: 
    Application domain: /LM/W3SVC/1901200390/ROOT-1-129944117181445077 
    Trust level: WSS_Minimal 
    Application Virtual Path: / 
    Application Path: C:\inetpub\wwwroot\wss\VirtualDirectories\80\ 
    Machine name:  

Process information: 
    Process ID: 1000 
    Process name: w3wp.exe 
    Account name: Domain\user

Exception information: 
    Exception type: InvalidOperationException 
    Exception message: There is an error in XML document (1, 43). 

Request information: 
    Request URL: http://www.website.ac.za/_layouts/aclinv.aspx?IsDlg=1 
    Request path: /_layouts/aclinv.aspx 
    User host address:  
    User: 0#.w|Domain\User 
    Is authenticated: True 
    Authentication Type: Federation 
    Thread account name: Domain\User 

Thread information: 
    Thread ID: 26 
    Thread account name: Domain\User
    Is impersonating: False 
    Stack trace:    at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader, String encodingStyle, XmlDeserializationEvents events)
   at System.Xml.Serialization.XmlSerializer.Deserialize(XmlReader xmlReader)
   at Microsoft.SharePoint.WebControls.EntityEditor.ParseSpanData(String spans)
   at Microsoft.SharePoint.WebControls.EntityEditor.LoadPostData(String postDataKey, NameValueCollection values)
   at System.Web.UI.Page.ProcessPostData(NameValueCollection postData, Boolean fBeforeLoad)
   at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)


Custom event details: 

Does somebody maybe have a solution for me on this?

share|improve this question
add comment

2 Answers

For some odd reason, this is related to IE9 (according to http://www.alectang.com/blog/archive/2012/04/24/system-invalidoperationexception--there-is-an-error-in-xml-document.aspx).

I used developer tools (F12) and changed my browser mode to IE8 and it worked around this issue. Doesnt explain why it happens, but allows you to work around it atleast..

share|improve this answer
add comment

Internet Explorer 11 fails no matter what, but Chrome 34 works fine (though it adds the user twice).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.