Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed virtualmin and played around with the DNS settings. Now when I try to start bind9 I get the error:

Service bind9 restart

 * Stopping domain name service... bind9   
   rndc: connect failed: 127.0.0.1#953: connection refused
                                                                    [ OK ]
 * Starting domain name service... bind9                            [fail]

/var/log/syslog

Oct 11 06:05:45 stock named[6316]: starting BIND 9.8.1-P1 -u bind
Oct 11 06:05:45 stock named[6316]: built with '--prefix=/usr' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--sysconfdir=/etc/bind' '--localstatedir=/var' '--enable-threads' '--enable-largefile' '--with-libtool' '--enable-shared' '--enable-static' '--with-openssl=/usr' '--with-gssapi=/usr' '--with-gnu-ld' '--with-geoip=/usr' '--enable-ipv6' 'CFLAGS=-fno-strict-aliasing -DDIG_SIGCHASE -O2' 'LDFLAGS=-Wl,-Bsymbolic-functions -Wl,-z,relro' 'CPPFLAGS=-D_FORTIFY_SOURCE=2'
Oct 11 06:05:45 stock named[6316]: adjusted limit on open files from 4096 to 1048576
Oct 11 06:05:45 stock named[6316]: found 4 CPUs, using 4 worker threads
Oct 11 06:05:45 stock named[6316]: using up to 4096 sockets
Oct 11 06:05:45 stock named[6316]: loading configuration from '/etc/bind/named.conf'
Oct 11 06:05:45 stock named[6316]: /etc/bind/named.conf.options:26: expected IPv4 address or '*' near ';'
Oct 11 06:05:45 stock named[6316]: loading configuration: unexpected token
Oct 11 06:05:45 stock named[6316]: exiting (due to fatal error)

/etc/bind/named.conf.options

options {
    directory "/var/cache/bind";

    // If there is a firewall between you and nameservers you want
    // to talk to, you may need to fix the firewall to allow multiple
    // ports to talk.  See http://www.kb.cert.org/vuls/id/800113

    // If your ISP provided one or more IP addresses for stable 
    // nameservers, you probably want to use them as forwarders.  
    // Uncomment the following block, and insert the addresses replacing 
    // the all-0's placeholder.

    // forwarders {
    //  0.0.0.0;
    // };

    //========================================================================
    // If BIND logs error messages about the root key being expired,
    // you will need to update your keys.  See https://www.isc.org/bind-keys
    //========================================================================
    dnssec-validation auto;

    auth-nxdomain no;    # conform to RFC1035
    listen-on-v6 { any; };
//  allow-recursion { 127.0.0.1; };
    transfer-source;
};
share|improve this question

2 Answers 2

up vote 0 down vote accepted

The error message is actually pretty self-explanatory. As documented in named.conf(4) the option transfer-source MUST be followed by either an IPv4 address or the token *, while you have just the bare keyword in line 26 of your configuration:

transfer-source;

Fix that and the error will go away.

share|improve this answer

You have problem in configuration in named.conf:

Oct 11 06:05:45 stock named[6316]: /etc/bind/named.conf.options:26: expected IPv4 address or '*' near ';'
Oct 11 06:05:45 stock named[6316]: loading configuration: unexpected token

If you edit named.conf on Windows you must convert named.conf to Unix format. You can use dos2unix from Linux.

share|improve this answer
    
Another option would be recode ibmpc..latin1 named.conf. That's not the reason for the error, though. –  Ansgar Wiechers Oct 11 '12 at 11:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.