Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to connect an Outlook (2010) client to my Exchange 2010 server I notice that its trying to use the local FQDN of the Exchange server to auto-connect. (computername.domainname.com)

This is not Ideal and preffered would be the global FQDN of the mailserver. (mail.domainname.com)

In DNS I have the following records for the Exchange Server: computername.domainname.com mail.domainname.com autodiscover.domainname.com

What should I change in my configuration to make Outlook automatically (local) connect with the global FQDN instead of the local machine name? (if this is possible at all off course)

Is it as simple as changing all the FQDN's on the Receive connectors in the Hub Transport? Or are there more things to consider?

I've tried searching for the answer but this question is a bit to specific to find a clear answer. Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I think the answer you're looking for would be to properly configure the autodiscover services to dish out the outlook anywhere external host name settings.

Outlook anywhere would force your clients to connect using mail.domainname.com and the settings would be picked up automatically using your autodiscover DNS record when you first configure Outlook.

I could also be very wrong though and be misunderstanding the question, because when you first configure Outlook the server name in the "Server" field always resolves to the local computer DNS name to the best of my knowledge.

EDIT: Also: goeiedag!

share|improve this answer
    
Hi Jason, Jij ook een goeiedag! :) Thanks for your answer I will try out the autodiscover tip and report back asap. I think you understood correct but for me the process is like this: Start outlook for the first time then Outlook will see your user and user email. Then click next and autodiscover finds all data needed to create the profile. After creation you will see in the server name the local name of the exchange server instead of the external url. I will go and check your tip now. –  Joost Verdaasdonk Oct 11 '12 at 14:12
    
Jason goal accomplished thanks –  Joost Verdaasdonk Oct 11 '12 at 19:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.