Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.


I am on an Amazon EC2, Suse installation which comes with a Apache 2.2.12. I am using HTTPS and want to turn off SSLCompression but it isn't available for Apache 2.2.12. I can't even upgrade Apache as the repository maintained by Amazon doesn't yet include Apache 2.4.3, not even Apache 2.2.24.
So since I'm stuck with it, is there anyway I can turn off SSLCompression in Apache 2.2.12?

share|improve this question
    
See related, which has an answer based on the bug report on redhat.com : serverfault.com/questions/455450/… –  Stefan Lasiewski Dec 8 '12 at 0:56

1 Answer 1

up vote 3 down vote accepted

There is no option to disable compression in Apache <= 2.2.23 mod_ssl.

You have few options to resolve this problem:

1) Wait for Apache 2.2.24 and compile from source: https://issues.apache.org/bugzilla/show_bug.cgi?id=53219

2) Use current stable Apache 2.2.23 and use patch for disabling compression from the link above

3) Use other frontend/proxy for SSL termination (for example nginx or pound)

share|improve this answer
    
I didn't wanted to install from an external source as resolving the dependencies would have been a pain. Anyways, I opted for the Amazon AMI(based on RedHat) and the repository it came with had Apache2.4 so I guess am good with it now. –  kumar Oct 16 '12 at 16:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.