Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a small office, with ATT Motorola modem (192.168.1.254) set as passthrough to Dlink DIR-815 (LAN 192.168.0.1) I am trying to setup DHCP server on Server 2012, and when I create new DHCP server, the title is created as 169.254.. instead of the domain name. (Domain clients can retrieve IP's as defined in the scope)

Non-domain clients are not receiving IP's from the server but rather the Motorola... How do I assure DHCP setup is properly creating itself, and how do I make sure domain and non-domain clients get IP's from the server?

share|improve this question
    
Is the Motorola configured as a DHCP server by AT&T? –  Dave M Oct 12 '12 at 19:58
    
Unfortunately, I cant disable the DHCP. No option. I thought passthrough was only suppose to act like a modem... –  Seth Oct 12 '12 at 20:01

3 Answers 3

up vote 4 down vote accepted

Are you sure those 169.254 address are being assigned via DHCP by the modem? Those aren't private subnet addresses, they're link local autoconfig addresses. They're supposed to be used by hosts that don't have a static IP and can't reach a DHCP server to get an authoritative address.

I would guess that your DHCP service isn't working and that the hosts are configuring themselves with that address range.

If those are Windows hosts, does ipconfig /renew return immediately with success or does it time out?

share|improve this answer
    
Let me elaborate a little bit. 2012 server has static ip set, when I go to "Create" the DHCP service/server, and where in previous version of server like 2008, and 2003, the title of the server is the server domain name. In this instance, instead of the domain name, it is given the name in address form as I said, 169.254. whatever –  Seth Oct 12 '12 at 21:41
1  
Does the server have more than one interface? Could it be pulling an autoconfig address from an unexpected interface? –  Chris Smith Oct 12 '12 at 21:43
    
no, only one interface active... –  Seth Oct 12 '12 at 21:45
    
facepalm I did not have other interfaced diabled, therefore binding caused the autconfig... Thanks Chris :-) –  Seth Oct 12 '12 at 21:56
    
No problem, we've all been there :) –  Chris Smith Oct 12 '12 at 22:08

The first reason that causes such problems is this still a network card that is connected. Even if no physical connection, it receives IP 169.254.xx series and can cause such problems. As a solution you can disable IPv4 to this network card. Or you can delete this address using netsh (http://technet.microsoft.com/en-us/library/cc731521(WS.10).aspx#BKMK_deleteaddress)

share|improve this answer

1) The DLink is supplying DHCP. No way in hell it comes from the Motorola or the provider, as the DLink is doing NAT (otherwise it wouldn't have 192.168.0.1 on the LAN side).
Disable DHCP on the DLink please.

2) An exact split between server and other DHCP server for domain and non-domain clients is bogus. When there are 2 DHCP servers both will reply to a DHCP request. The client will decide which offer to accept. If the client had history with one of them it will usually accept the offer of the server it most recently talked to. This may appear as if the domain-clientonly talk to the 2012 server, but that is not really what is happening.

My best guess: The 2012 server originally didn't get DHCP and auto-generated the address. DHCP server on the machine was made active at that moment. Afterwards you set the static IP, but you didn't restart the DHCP service so it didn't pick up on that. It will probably will look normal after a reboot of the server.

share|improve this answer
    
DHCP is disabled on DLINK. 0.1 is the schema for dlink, 1.1 is the schema for modem. Wireless devices are receiving 1.1 addresses... 1.1 is not setup anywhere except the modem. –  Seth Oct 12 '12 at 22:29
    
further examination, shows my phone getting ip from server. I will look to see if the other wireless devices is looking at history for its ip... –  Seth Oct 12 '12 at 22:39
    
@Seth So the Motorola is acting as a NAT router, with DHCP and the DLink is passing that through it's own NAT. Which is strange as NAT devices usually filter out DHCP requests unless they are configured as DHCP-relay at the same time (not available in DLinks the last time I looked). If you can't disable DHCP on the Moto you might be able to break the DHCP traversal in the DLink by setting up port-forwarding (in the DLink) of ports 67 and 68 UDP to an unused ip-address. I'm not sure if that would work, but it is worth a try. –  Tonny Oct 13 '12 at 8:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.