Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want that when people access my web server with the ip address, like http://10.0.0.1, be redirected to the domain name, like http://example.com. I'm using Apache Web Server and I've tried:

<VirtualHost 10.0.0.1:80>
    Redirect / http://example.com
</VirtualHost>

which generated an infinite recursion because it has higher priority than

<VirtualHost *:80>
    ServerName example.com
    ...
</VirtualHost>

which is the virtual host I ultimately want to serve.

I've also tried

<VirtualHost 10.0.0.1:80>
    ServerName 10.0.0.1
    Redirect / http://example.com
</VirtualHost>

thinking that maybe it'll only match http://10.0.0.1 but not http://example.com. But it also generate an infinite loop. Any ideas how to achieve that?

The reason why the IP virtual host is not the main and only virtual host is because I want other IPs on the server to also be able to server example.com.

share|improve this question
1  
What about your NameVirtualHost setting ? –  radius Jul 22 '09 at 5:23
add comment

2 Answers 2

HD answered gave a good rewrite rule, but you should put a condition before that. Make sure that there is only one virtual host running on 10.10.10.1 and have your definition look like the following:

<VirtualHost 10.0.0.1:80>
    ServerName servername.com
    .....

    RewriteCond %{SERVER_NAME} 10.10.10.1
    RewriteRule /(.*) http://servername.com/$1 [R=301,L]

</VirtualHost>

This way, you only need one virtual host for that IP address instead of what you were trying to do above. NOTE: If you're going to have more than one virtual host on this server, you need to put the rest on different IP(s)

share|improve this answer
    
Shouldn't the rewrite condition try to match the virtual host ip, like 10.0.0.1 instead of 10.10.10.1? Why would other virtual hosts need to run in different IPs? Won't they match by name instead of IP? –  J. Pablo Fernández Aug 5 '10 at 8:30
    
In my case it was also neccessary to add RewriteEngine On before the RewriteCond line. –  lanoxx May 8 '12 at 20:36
add comment

I try the same configuration and it works fine. Are you sure there is no other definition that conflicts with your virtual hosts? What is the error in the apache logs?

This rule also works:

RewriteRule ^(.*)$ http://example.com/$1 [R=301,NC]
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.