Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've very basic understanding of linux systems, but I've a server which was setup a while ago to host some web apps. Recently I decided to test out and implement Sphinx but unfortunately I cant get the install to work.

I'm running a Debian Lenny distro and when I try to install sphinx it says -

checking MySQL include files... configure: error: missing include files.

******************************************************************************
ERROR: cannot find MySQL include files.

Check that you do have MySQL include files installed.
The package name is typically 'mysql-devel'.

If include files are installed on your system, but you are still getting
this message, you should do one of the following:

1) either specify includes location explicitly, using --with-mysql-includes;
2) or specify MySQL installation root location explicitly, using --with-mysql;
3) or make sure that the path to 'mysql_config' program is listed in
   your PATH environment variable.

To disable MySQL support, use --without-mysql option.
******************************************************************************

I do have mysql 5.1 installed but I can't find the include files, AND one more thing.. I read around the net that I probably need libmysqlclient15-dev but when I try to install that using apt-get i receive the following error.

The following packages were automatically installed and are no longer required:
  libxcb-aux0 libts-0.0-0 libxcb-atom1 ttf-dejavu-extra hunspell-en-us g++-4.3
  libmysql++3 libnspr4-0d libdirectfb-1.0-0 libxcb-event1 libasound2
  libstdc++6-4.3-dev libhunspell-1.2-0 ttf-dejavu libmozjs2d
  conkeror-spawn-process-helper libnss3-1d
Use 'apt-get autoremove' to remove them.
The following NEW packages will be installed:
  libmysqlclient15-dev
0 upgraded, 1 newly installed, 0 to remove and 276 not upgraded.
Need to get 7590 kB of archives.
After this operation, 26.3 MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  libmysqlclient15-dev
Install these packages without verification [y/N]? Y
Err http://ftp.us.debian.org/debian/ lenny/main libmysqlclient15-dev amd64 5.0.51a-24+lenny5
  404  Not Found [IP: 35.9.37.225 80]
Err http://security.debian.org/ lenny/updates/main libmysqlclient15-dev amd64 5.0.51a-24+lenny5
  404  Not Found [IP: 149.20.20.6 80]
Failed to fetch http://security.debian.org/pool/updates/main/m/mysql-dfsg-5.0/libmysqlclient15-dev_5.0.51a-24+lenny5_amd64.deb  404  Not Found [IP: 149.20.20.6 80]
E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

Can you help me out by suggesting how to install the required packages and run the Sphinx.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

Yes the problem you are experiencing is called deprecation. Lenny is no longer supported by Debian (for a year now I think) so it can't find the files in the repositories simply because they do not exist anymore. Your only chance is to upgrade your machine to the next stable version, which is "Squeeze".

share|improve this answer
    
Thanks Lucas. Got it running. –  Ando Oct 14 '12 at 22:47
add comment

Lucas is right; if for some reason [and let it be a good one because you should not do it on any internet-reachable server] you have to stick to lenny - edit your /etc/apt/sources.list and change http://some.mirror/ to http://archive.debian.org/ ; run apt-get update and install what you need.

share|improve this answer
    
Thanks for the response! Upgraded everything, installed and things seem to be working good. –  Ando Oct 14 '12 at 22:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.