Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a strange networking problem with Windows 2008 server R2, running as guest under KVM-Qemu host. Host is CentOS 6.3 x86_64. It's network settings:

# cat /etc/sysconfig/network-scripts/ifcfg-br0
DEVICE=br0
BOOTPROTO=static
BROADCAST=xx.xx.xx.63
IPADDR=xx.xx.xx.4
NETMASK=255.255.255.192
NETWORK=xx.xx.xx.0
ONBOOT=yes
TYPE=Bridge

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
HWADDR=xx:xx:xx:xx:xx:xx
ONBOOT=yes
BRIDGE=br0
IPV6INIT=yes
IPV6_AUTOCONF=yes

# cat /etc/sysconfig/network
NETWORKING=yes
NETWORKING_IPV6=no
HOSTNAME=my.hostname
GATEWAY=xx.xx.xx.1

# cat /etc/sysctl
net.ipv4.ip_forward = 1   # tried to set it to 0 without any changes
net.ipv4.conf.default.rp_filter = 1   # tried to set it to 0 without any changes
net.ipv4.conf.default.accept_source_route = 0   # tried to set it to 1 without any changes
kernel.sysrq = 0
kernel.core_uses_pid = 1
net.ipv4.tcp_syncookies = 1
net.bridge.bridge-nf-call-ip6tables = 0
net.bridge.bridge-nf-call-iptables = 0
net.bridge.bridge-nf-call-arptables = 0
kernel.msgmnb = 65536
kernel.msgmax = 65536
kernel.shmmax = 68719476736
kernel.shmall = 4294967296

# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
xx.xx.xx.0      0.0.0.0         255.255.255.192 U     0      0        0 br0
169.254.0.0     0.0.0.0         255.255.0.0     U     1004   0        0 br0
0.0.0.0         xx.xx.xx.1      0.0.0.0         UG    0      0        0 br0

Node IP is xx.xx.xx.4, guest IP is xx.xx.xx.24, both host and guest is in the same network (/26). There are several linux guest running fine on the node (centos, debian, ubuntu, arch), and even Windows 2003 x86 also running fine. But Win2008 does not. I wonder, what's the difference. From Win2008 guest I can ping nothing: neither gateway, nor any other IP, even they are in the same subnet. From outside I also cannot ping guest. Almost. If I ping it from another server in same subnet, it's barely pinging, losing more than 90% packets. Firewall on the guest is completely off. Tried to set up network manually as well as via DHCP without success (BTW, DHCP set up network settings correctly). I suspect that is a kind of routing problem, but I spent whole day and still cannot figure it out. I would be appreciate for any help.

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Finally, I figured it out myself. The problem was in Proxy ARP setting in sysctl. It's turned off by default. I just added in /etc/sysctl.conf the string as follows:

net.ipv4.conf.all.proxy_arp = 1

and it works perfect now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.