Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sorry, if anyone can think of a better title please change it!

I want to host my own websites from home. For testing purposes, I have a virtual machine running a trial version of Windows Server 2008 Enterprise.

Note I currently run a VPS and host my own websites but due to a nice speed upgrade on our line I now want to host from home.

I have several domains but I wanted to test with one, that is rickyoleary.com.

Our ISP does not provide static IP addresses unless we have a business account so I've been looking at no-ip.com. I admit my networking isn't the best, hence this question but I've been bashing my head all day on this one.

I created a host name, muffinbubble.no-ip.org which runs on IP: 86.148.124.15.

I've setup IIS on the server with a simple test page. I've then forwarded port 80 traffic from the router and from what I can see, it's working. If I access my website (I was unable to link to this for some reason so please copy and paste this) - http://86.148.124.15/ - I see my test page.

So the next step was to create my nameservers. This domain is with namecheap.com so I created my nameservers, ns1.rickyoleary.com and ns2.rickyoleary.com. Both these point to the same IP (and yes, that will be changed after testing), the same IP as above: 86.148.124.15.

On the server itself I have set up DNS entries as below which I believe to be correct and added rickyoleary.com and www.rickyoleary.com in the host headers (or bindings) in IIS 7.0.

DNS

If I try and look up my domain, rickyoleary.com it shows ns1.rickyoleary.com and ns2.rickyoleary.com as the nameservers.

I then tried to use just-ping.com on my nameserver ns1.rickyoleary.com. I get 100% packets lost, but the correct IP address is returned (I'm guessing the router does not allow pings, but is still accessible...).

I get no response when pinging rickyoleary.com.

Here's the problems:

  1. I cannot ping ns1.rickyoleary.com or ns2.rickyoleary.com from a command prompt. I'm not sure if this is an issue.
  2. When I added the nameservers in Windows Server 2008 and clicked 'resolve' a message box displays stating "No such host is known".
  3. I cannot ping rickyoleary.com.
  4. rickyoleary.com is not showing my test page on my server.

Now - please note, I've waited around 6 hours for propagation. From my experience, although you're told to wait 24 - 48 hours, the changes are normally pretty quick so perhaps I'm being impatient or naive to think it should all be working fine until then.

I would really appreciate some help here.

Thanks.

share|improve this question

closed as off topic by Shane Madden, Tim Brigham, rnxrx, Magellan, Ward Oct 15 '12 at 2:31

Questions on Server Fault are expected to relate to server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

2 Answers 2

You say you've forwarded port 80 from your router to your server. This should cover standard http traffic (which uses that port by default).

You will also need to do the same for port 53 if you want any DNS traffic to get to your server.

share|improve this answer
    
This. Just checked with intodns.com and it couldn't resolve the domain, because both name servers didn't responds. –  c2h5oh Oct 15 '12 at 1:57

I ran into a similar issue with our own branded name servers a few years ago. You will need to setup glue records for ns1 and ns2 at Namecheap if you're going to host your own name servers. Here's more info on that issue: https://community.namecheap.com/forums/viewtopic.php?f=6&t=3522

However, if you're running DNS from the same dynamic IP address, I'm not sure how successful that will be. DNS servers need to be A records. So, you will need some way (if possible) to have your DNS server update the IP addresses for ns1 and ns2 instead of trying to CNAME them to your no-ip.com host name.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.