Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to setup an FTP server on Windows 2008 Server. I can connect locally:

C:\>ftp localhost
Connected to WebHead1
220 Microsoft FTP Service

However, when I try to connect from remote, it doesn't work:

~>ftp x.x.x.x
ftp: Can't connect to `x.x.x.x': Operation timed out
ftp: Can't connect to `x.x.x.x'

I've tried everything I can think of with the settings. The FTP server is bound to all unassigned IPs and listening on port 21. I've also checked "FTP Server" in the firewall settings. Nothing appears in the FTP log files. I'm totally out of ideas!

share|improve this question
    
Gents, I've attempted the advice you had here to discover that Passive mode is enabled if you go to Firewall Support for the FTP site. If you enter the public IP address in the Firewall Support, it will enable Passive Mode for the FTP site. If you remove the IP address from Firewall Support, it will start working. You will need to make sure to check both the server level and the ftp site level. – user284035 Apr 28 '15 at 3:27
up vote 20 down vote accepted

Figured it out. The issue is documented here.

Basically, you have to run:

sc sidtype ftpsvc unrestricted

And then restart the FTP service:

net stop ftpsvc & net start ftpsvc

From what I can tell, it's a bug in R2. Go figure.

share|improve this answer
    
Confirmed as working for Windows Server 2012 and IIS 8... – cederlof Jan 10 '14 at 12:46
2  
I can confirm the exact same issue occurs in Server 2012 IIS and this solution fixes it. – takesides Oct 6 '14 at 15:06
    
This solution works for Windows Pro 7 FTP Server. thanks. – jacouh Oct 26 '14 at 17:52
    
Confirmed still necessary in Aug '15, and has worked for me. – frumbert Aug 24 '15 at 0:59
    
Confirmed and is working. I had this issue on Windows server 2012 and IIS 8. Used the above commands and ftp is now working fine. Thanks for sharing buddy :) – Altaf Hussain Feb 11 at 7:36

protected by Community Oct 9 '15 at 15:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.