Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'have configured apache to use ssl certificates, when I type https://mysite.com it connects on local, but when I try outside of the server, it doesn't connect.

Here are my config and other details, I hope some one can help me.

Firewall exception for port 443 is enabled.

OS :

windows server 2008 R2

Web server:

AppServ 2.5.10(Apache 2.2.8,PHP 5.2.6,MySQL 5.0.51b,phpMyAdmin-2.10.3)

Note: I have purchased the domain at godaddy.com , when I type, www.mysite or mysite.com it works good(it have been working good since 2 years ago)

httpd.conf file

Added :

Listen 443

uncomment:

LoadModule ssl_module modules/mod_ssl.so

added:

<VirtualHost 23.23.95.84:80>
DocumentRoot  C:/AppServ/www/SaresInterno 
ServerName staging.soluntech.com 
SSLEngine on
SSLCertificateFile C:/AppServ/Apache2.2/conf/certificate.crt  
SSLCertificateKeyFile C:/AppServ/Apache2.2/conf/ssl.key 
SSLCertificateChainFile C:/AppServ/Apache2.2/conf/sub.class1.server.ca.pem
SSLCACertificateFile C:/AppServ/Apache2.2/conf/ca.pem
SSLProtocol all -SSLv2
SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
CustomLog  C:/AppServ/Apache2.2/logs/ssl_request_log \
"%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>

<VirtualHost _default_:443>
DocumentRoot  C:/AppServ/www/SaresInterno 
ServerName staging.soluntech.com 
SSLEngine on
SSLCertificateFile C:/AppServ/Apache2.2/conf/certificate.crt  
SSLCertificateKeyFile C:/AppServ/Apache2.2/conf/ssl.key 
SSLCertificateChainFile C:/AppServ/Apache2.2/conf/sub.class1.server.ca.pem
SSLCACertificateFile C:/AppServ/Apache2.2/conf/ca.pem
 SSLProtocol all -SSLv2
   SSLCipherSuite ALL:!ADH:!EXPORT:!SSLv2:RC4+RSA:+HIGH:+MEDIUM
   SetEnvIf User-Agent ".*MSIE.*" nokeepalive ssl-unclean-shutdown
   CustomLog  C:/AppServ/Apache2.2/logs/ssl_request_log \
      "%t %h %{SSL_PROTOCOL}x %{SSL_CIPHER}x \"%r\" %b"
</VirtualHost>
share|improve this question

migrated from stackoverflow.com Oct 15 '12 at 6:05

This question came from our site for professional and enthusiast programmers.

    
Don't put the SSL directives (in particular SSLEngine on) in your virtualhost on port 80. Have you checked your firewall? –  Bruno Oct 12 '12 at 21:27
    
Yes I have, if I type onm console, telnet myip 443 from a remote location , it connects. Gonna comment the SSLEngine on in my virtual host port 80 –  Guille Oct 13 '12 at 15:02
    
What does "it doesn't work" mean? Certificate error? Can't connect? Internal server error? –  David Oct 15 '12 at 6:09
    
Hi David, It Can't connect remotely, but connect locally. –  Guille Oct 16 '12 at 18:42

1 Answer 1

for test re-configure apache to serve content on port 443 instead of port 80 and try to hit it from outside, if you still unable to do so then it's not apache it's most likely firewall (yes i know you said its in the list, but maybe there is another firewall or something else is blocking request)

share|improve this answer
    
Hi Alexus, thanks for your time, This server is located on Amazon EC2, it is virtual, and I have enabled port 443, in Amazon EC2 Console, and also in windows 2008, but no luck, the other ports, like 80, 3306 for my sql, connect succefully , and I always do the same steps. 1. Enable ports on Ec2 Cosole. 2. Enable ports on windows 2008 firewall. I don't know if is some windows firewall issue with windows firewall, microsoft says that install latest updates, but still not connect. –  Guille Oct 17 '12 at 16:19
    
my guess since you're able to access https (port 443) locally then it's most likely not SSL at fault, but rather Windows/Amazon where the problem is, maybe you enabled port 443 on Amazon Console for one policy yet using another policy for that VM (you have to verify that) same goes for Windows firewall, maybe you have another peace of software that is blocking that port. –  alexus Oct 17 '12 at 16:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.